Opened 4 years ago

Closed 3 years ago

#58713 closed defect (fixed)

ispc: Use newer llvm

Reported by: ryandesign (Ryan Schmidt) Owned by: tenomoto (Takeshi Enomoto)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia)
Port: ispc

Description

ispc fails to install, because it depends upon llvm-3.9, which was removed from MacPorts:

$ sudo port install ispc
--->  Computing dependencies for ispc
--->  Dependencies to be installed: clang-3.9
--->  Fetching distfiles for clang-3.9
--->  Verifying checksums for clang-3.9
--->  Extracting clang-3.9
--->  Configuring clang-3.9
Error: clang-3.9 has been replaced by clang-8.0; please install that instead.

Please switch to a newer version of llvm. A new version of ispc is available, in case that provides compatibility with a newer llvm version.

Change History (1)

comment:1 Changed 3 years ago by tenomoto (Takeshi Enomoto)

Resolution: fixed
Status: assignedclosed

In e0c9fb49a4e4446e4bb88d9e69fa45fc1019ac4a/macports-ports (master):

ispc: update to 1.11.0

Closes: #58637
Closes: #58713

Note: See TracTickets for help on using tickets.