Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#58840 closed defect (fixed)

libuv fails to build on 10.8.5

Reported by: dmitriz (Dmitri Zaitsev) Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: libuv

Description

✗ sudo port install libuv
--->  Computing dependencies for libuv
--->  Fetching distfiles for libuv
--->  Verifying checksums for libuv
--->  Extracting libuv
--->  Applying patches to libuv
--->  Configuring libuv
--->  Building libuv
Error: Failed to build libuv: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_libuv/libuv/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port libuv failed

Here are the parts from the log file with the errors:

:info:build libtool: link: /usr/bin/clang -dynamiclib  -o .libs/libuv.1.dylib  src/.libs/libuv_la-fs-poll.o src/.libs/libuv_la-idna.o src/.libs/libuv_la-inet.o src/.libs/libuv_la-strscpy.o src/.libs/libuv_la-threadpool.o src/.libs/libuv_la-timer.o src/.libs/libuv_la-uv-data-getter-setters.o src/.libs/libuv_la-uv-common.o src/.libs/libuv_la-version.o src/unix/.libs/libuv_la-async.o src/unix/.libs/libuv_la-core.o src/unix/.libs/libuv_la-dl.o src/unix/.libs/libuv_la-fs.o src/unix/.libs/libuv_la-getaddrinfo.o src/unix/.libs/libuv_la-getnameinfo.o src/unix/.libs/libuv_la-loop-watcher.o src/unix/.libs/libuv_la-loop.o src/unix/.libs/libuv_la-pipe.o src/unix/.libs/libuv_la-poll.o src/unix/.libs/libuv_la-process.o src/unix/.libs/libuv_la-signal.o src/unix/.libs/libuv_la-stream.o src/unix/.libs/libuv_la-tcp.o src/unix/.libs/libuv_la-thread.o src/unix/.libs/libuv_la-tty.o src/unix/.libs/libuv_la-udp.o src/unix/.libs/libuv_la-bsd-ifaddrs.o src/unix/.libs/libuv_la-darwin.o src/unix/.libs/libuv_la-darwin-proctitle.o src/unix/.libs/libuv_la-fsevents.o src/unix/.libs/libuv_la-kqueue.o src/unix/.libs/libuv_la-proctitle.o   -L/opt/local/lib -lMacportsLegacySupport -lpthread -ldl  -Os -arch x86_64 -g -Os -arch x86_64 -g -Wl,-headerpad_max_install_names -arch x86_64   -install_name  /opt/local/lib/libuv.1.dylib -compatibility_version 2 -current_version 2.0 -Wl,-single_module
:info:build duplicate symbol ___sincosf in:
:info:build     src/unix/.libs/libuv_la-darwin-proctitle.o
:info:build     src/unix/.libs/libuv_la-fsevents.o
:info:build duplicate symbol ___sincos in:
:info:build     src/unix/.libs/libuv_la-darwin-proctitle.o
:info:build     src/unix/.libs/libuv_la-fsevents.o
:info:build ld: 2 duplicate symbols for architecture x86_64
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:build make: *** [libuv.la] Error 1
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_libuv/libuv/work/libuv-1.31.0'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_libuv/libuv/work/libuv-1.31.0" && /usr/bin/make -j8 -w all 
:info:build Exit code: 2
:error:build Failed to build libuv: command execution failed
:debug:build Error code: CHILDSTATUS 72205 2
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring"
:debug:build     invoked from within
:debug:build "command_exec build"
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname"
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_libuv/libuv/main.log for details.

Any hint what might be the problem?

Attachments (2)

log (155.4 KB) - added by dmitriz (Dmitri Zaitsev) 14 months ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_libuv/libuv/main.log
log1 (11.8 KB) - added by dmitriz (Dmitri Zaitsev) 14 months ago.
errors running sudo port install libuv

Download all attachments as: .zip

Change History (18)

comment:1 Changed 14 months ago by cjones051073 (Chris Jones)

Please always attached the *complete* log when submitting a trac ticket.

comment:2 Changed 14 months ago by cjones051073 (Chris Jones)

In the meantime....

I wonder if this is related to a recent addition I made to the legacy support package

https://github.com/macports/macports-legacy-support/commit/ebbdbf99c6ba81055625451053d4af39e48ac3b7

My understanding was these are missing in 10.8, but perhaps just the declaration is missing in the headers and the library symbols actually still exist, hence the above.

Let me fire up my 10.8 VM and take a look.

comment:3 Changed 14 months ago by letaage

Cc: letaage added

comment:4 Changed 14 months ago by letaage

Cc: letaage removed

comment:5 Changed 14 months ago by letaage

Cc: letaage added

Changed 14 months ago by dmitriz (Dmitri Zaitsev)

Attachment: log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_libuv/libuv/main.log

comment:6 Changed 14 months ago by dmitriz (Dmitri Zaitsev)

Please always attached the *complete* log when submitting a trac ticket.

Sorry, please see the 'log' file attached, thank you!

comment:7 Changed 14 months ago by cjones051073 (Chris Jones)

OK, I think I know what was wrong.

I have pushed updates to legacy-support{-devel} to hopefully address it. Please wait for this update to come though for you and try again.

comment:8 Changed 14 months ago by cjones051073 (Chris Jones)

closing this, as I have confirmed it fixes the issue for me with my 10.8 VM.

comment:9 Changed 14 months ago by cjones051073 (Chris Jones)

Resolution: fixed
Status: newclosed

comment:10 Changed 14 months ago by dmitriz (Dmitri Zaitsev)

Ah, thanks a lot! How will I know when your update is active?

comment:11 Changed 14 months ago by mf2k (Frank Schima)

Keywords: libuv removed

comment:12 Changed 14 months ago by ryandesign (Ryan Schmidt)

Changes made to our git repository should be visible on the rsync server (and therefore obtainable via sudo port sync) within about an hour of being committed.

Changed 14 months ago by dmitriz (Dmitri Zaitsev)

Attachment: log1 added

errors running sudo port install libuv

comment:13 Changed 14 months ago by dmitriz (Dmitri Zaitsev)

More errors, please see the new attached file log1.

✗ sudo port sync
--->  Updating the ports tree
✗ sudo port install libuv
--->  Verifying checksums for legacy-support
Error: Failed to checksum legacy-support: macports-legacy-support-0.11.1.tar.gz does not exist in /opt/local/var/macports/distfiles/legacy-support
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_legacy-support/legacy-support/main.log for details.
Error: Unable to execute port: upgrade legacy-support failed

comment:14 Changed 14 months ago by dmitriz (Dmitri Zaitsev)

No luck with port clean either, the same errors after.

Attempting to uninstall threatens to break other ports:

✗ sudo port uninstall libuv
Note: It is not recommended to uninstall/deactivate a port that has dependents as it breaks the dependents.
The following ports will break:
 cmake @3.15.0_0
 cmake @3.15.1_0
Continue? [y/N]: N
--->  Cleaning libuv

comment:15 Changed 14 months ago by kencu (Ken)

So your issue seems to be with downloading legacy-support... that's a bit unusual. Best bet is to try again:

sudo port selfupdate
sudo port clean legacy-support
sudo port -v install legacy-support

that should give you a current installation of legacy-support to work with. Then try libuv:

sudo port clean libuv
sudo port -v install libuv

and you should be in business.

comment:16 Changed 14 months ago by letaage

Cc: letaage removed
Note: See TracTickets for help on using tickets.