Opened 3 years ago

Closed 3 years ago

#58911 closed defect (fixed)

ledger 3.1.3: needs to be rebuilt/relinked against boost 1.71

Reported by: rcobbe Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: cjones051073 (Chris Jones)
Port: ledger

Description

The prebuilt ledger 3.1.3 binary available for Mojave appears to need to be rebuilt and/or relinked against the recently released boost 1.71. Attempting to run the prebuilt binary against the new boost produces the failure text in the attached file. Downgrading to boost 1.70 fixes the problem, as does reinstalling ledger from source (port install -s ledger) when boost 1.71 is active.

Attachments (1)

ledger-error.txt (483 bytes) - added by rcobbe 3 years ago.
load-time error message

Download all attachments as: .zip

Change History (2)

Changed 3 years ago by rcobbe

Attachment: ledger-error.txt added

load-time error message

comment:1 Changed 3 years ago by jmroot (Joshua Root)

Cc: cjones051073 added
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.