Opened 2 months ago

Last modified 2 months ago

#58913 assigned defect

lilypond-devel fails to configure on Mojave

Reported by: joelmeyerhamme (Joel Meyer-Hamme) Owned by: nerdling (Jeremy L)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc:
Port: lilypond-devel

Description

Configuring lilypond-devel fails very quickly

% sudo port install -dt lilypond-devel
--->  Computing dependencies for lilypond-devel
--->  Configuring lilypond-devel
Error: Failed to configure lilypond-devel, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_textproc_lilypond-devel/lilypond-devel/work/lilypond-2.19.83/config.log
Warning: The following existing files were hidden from the build system by trace mode:
  /opt/local/bin/clang-mp-8.0
  /var/db/timezone/zoneinfo/Europe/Berlin
Error: Failed to configure lilypond-devel: configure failure: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_textproc_lilypond-devel/lilypond-devel/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port lilypond-devel failed

I think the revelant lines from main.log are

:info:configure checking whether the C compiler works... no
:info:configure configure: error: in `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_textproc_lilypond-devel/lilypond-devel/work/lilypond-2.19.83':
:info:configure configure: error: C compiler cannot create executables
:info:configure See `config.log' for more details
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_textproc_lilypond-devel/lilypond-devel/work/lilypond-2.19.83" && autoconf -f && ./configure --prefix=/opt/local --with-urwotf-dir=/opt/local/share/fonts/urw-core35-fonts --enable-documentation --with-texgyre-dir=/opt/local/share/texmf-texlive/fonts/opentype/public/tex-gyre 
:info:configure Exit code: 77

Manually running autoconf and configure fails after a much longer time with

ERROR: Please install required programs:  guile-config (guile-devel, guile-dev or libguile-dev package) libguile (libguile-dev, guile-devel or guile-dev package). GUILE-with-rational-bugfix

(which seems odd to me – )

Notably, checking whether the C compiler works... yes is successful when manually running configure.

Attachments (1)

main.log (1.0 MB) - added by joelmeyerhamme (Joel Meyer-Hamme) 2 months ago.

Download all attachments as: .zip

Change History (5)

Changed 2 months ago by joelmeyerhamme (Joel Meyer-Hamme)

Attachment: main.log added

comment:1 Changed 2 months ago by kencu (Ken)

that config.log will have the attempted compile line that failed -- that is usually your best bet to see what actually happened when you see those C compiler cannot create executables messages.

comment:2 Changed 2 months ago by jmroot (Joshua Root)

Owner: set to nerdling
Status: newassigned

Does it work if you don't use trace mode?

comment:3 Changed 2 months ago by joelmeyerhamme (Joel Meyer-Hamme)

Cc: joelmeyerhamme added

comment:4 Changed 2 months ago by joelmeyerhamme (Joel Meyer-Hamme)

Cc: joelmeyerhamme removed
Note: See TracTickets for help on using tickets.