Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#58923 closed defect (duplicate)

clang-8.0 @8.0.0_1 does not build on mavericks

Reported by: tehcog (tehcog) Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia), larryv (Lawrence Velázquez)
Port: clang-8.0

Description

Sep 03 17:46:03 xxxXXXxxx Error: Failed to build clang-8.0: command execution failed
Sep 03 17:46:03 xxxXXXxxx Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-8.0/clang-8.0/main.log for details.

Please see attached log file

Attachments (1)

clang8_main.log (2.8 MB) - added by tehcog (tehcog) 3 years ago.
main.log

Change History (5)

Changed 3 years ago by tehcog (tehcog)

Attachment: clang8_main.log added

main.log

comment:1 Changed 3 years ago by kencu (Ken)

This is that same error in go again.

See: 58917

Duplicate of: 58592

Last edited 3 years ago by kencu (Ken) (previous) (diff)

comment:2 Changed 3 years ago by kencu (Ken)

So lets see what is up here. If go happens to be installed, then clang tries to build the go bindings. On 10.9 and less, go is sometimes installed, but it's broken, so the build of clang fails.

So we should see if we can disable the go bindings in clang (that would be nice, if possible), or we should not allow the go port to install on a system where it will be broken when it is run (that would be the better fix).

Of course, WRT MacPorts, clang should not opportunistically build the go bindings. We should either install the bindings, or not install the bindings.

For the original poster, if you deactivate go -- it's broken anyway -- then you should be able to install clang-8.0 and be on your way again.

comment:3 Changed 3 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

comment:4 Changed 3 years ago by tehcog (tehcog)

Yes, it worked. Thanks Ken.

Note: See TracTickets for help on using tickets.