Opened 18 months ago

Last modified 5 months ago

#59003 assigned defect

Xwindow server doesn't launch

Reported by: ryanmckaynmr (Ryan McKay) Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc:
Port: xorg-server

Description

Dear All, Brand new. Usually use XQuartz without issue. Trying MacPorts for first time. Installed X11 app doesn't launch just bounces for 1 minute then locks up. Force quit only option. Tried XQuartz it works. Uninstalled XQuartz and reinstalled MacPorts. No luck. Installed the server and developer. Xcode 10.3 comes up under port diagnose. Tried forums, can't get into user forum. Tried GitHub, couldn't figure out what I was to do. Trying here. Fresh install of MacOS X 10.14.6

Change History (6)

comment:1 Changed 18 months ago by jmroot (Joshua Root)

Keywords: X11 window display removed
Owner: set to jeremyhu
Port: xorg-server added; org-server removed
Status: newassigned

comment:2 Changed 18 months ago by kencu (Ken)

MacPorts xorg-server and XQuartz are pretty much the same thing -- the XQuartz developer uses MacPorts to build it. So we're pretty close here.

You should be pretty close to functional if you

sudo port -v install xorg-server

That runs on every single macOS system from Tiger PPC right on up to the most current versions.

Once you have it installed, logout and log back into your account. That helps set things up correctly.

Then, in /Applications/MacPorts/ run X11.app by double clicking on it.

You should see menus, and be able to open an Xwindows terminal (xterm) from there.

If that doesn't work for you, please try running it from the command line in a Terminal window, like this:

/opt/local/bin/Xquartz

Please report back success or failure.

comment:3 Changed 18 months ago by ryanmckaynmr (Ryan McKay)

Good afternoon, I updated to Mac ports 2.6.0. Still can't use the /Applications/MacPorts/X11 app....it just bounces in the dock forever. Nothing happens. I used your command line /opt/local/bin/Xquartz and it opened!! I can't move the xterm window but I was able to open X11. Apples Terminal.app still doesn't open anything under any circumstances. e.g. "xterm" in Terminal.app does nothing, no window opens.

comment:4 Changed 5 months ago by bllxxm

Hello.

I think I have the same problem as ryanmckaynmr above. I have a fresh installation of Macports on macOS 10.13.6, with XCode 10.1 and command line tools installed. I successfully installed and ran several ports. Decided to install the xorg-server from MacPorts (as recommended in MacPorts installation guide), for X11. After installation, firing up /Applications/MacPorts/X11 caused the X11 program icon to bounce in the dock for a few minutes, then it settled but there was no marker below the program icon to indicate that it was running. Running ‘top’ in macOS Terminal showed two instances of X11.bin. Starting installed X-programs like xclock, from the macOS Terminal, did nothing.

I finally came across this bug report thread, and tried ‘/opt/local/bin/Xquartz’ from the Terminal: X11 ran! The program menus are active, and I can run X11 programs by invoking them from macOS Terminal. Excellent! I can also now run X11 by double-clicking it in the Finder, having run ‘/opt/local/bin/Xquartz’ once.

This brings that installation to the same stage I am at with another more modern machine’s fresh installation of MacPorts, on 10.15.7, with XCode GM 12.1 and command line tools installed, and the xorg-server installation from MacPorts.

*Both* the above machines do not produce a terminal window when I fire up X11. The X11 program’s menus are active and I can run X11 programs from macOS Terminal, but if I choose Terminal from the X11 menu, I get nothing. In the past when I have started X11 I always got an X11 terminal window, different to the macOS Terminal window.

Could someone let me know if I should be getting an X11 terminal window when I fire up X11, and if so, what I might try next to get one?

Thanks.

comment:5 Changed 5 months ago by kencu (Ken)

If you install the xterm port, you should find happiness.

Or you just install xorg and you get the entire X11 ecosystem, which is what I usually do.

comment:6 Changed 5 months ago by bllxxm

He's not wrong! Happy days...

Note: See TracTickets for help on using tickets.