Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#59031 closed defect (fixed)

libpftputil should not install util.h, shadows /usr/include/util.h

Reported by: TheLastLovemark Owned by: jmroot (Joshua Root)
Priority: Normal Milestone:
Component: ports Version: 2.5.4
Keywords: Cc:
Port: libpftputil python37

Description

I have a lot of ports that I am trying to upgrade including wireshark (which now requires python37), sslscan and others. All depend on openssl, which I can confirm is installed:

$ port installed openssl
The following ports are currently installed:
  openssl @1.0.2r_0+universal
  openssl @1.0.2s_0+universal
  openssl @1.1.1c_0+universal (active)

this problem may be related or similar to issue #58232 (filed by me, which I'm not sure is fixed, but involved libssl)

the logfiles for python37+optimizations and sslscan are attached

Thanks for your help

Attachments (3)

python37_main.log (133.5 KB) - added by TheLastLovemark 15 months ago.
sslscan_main.log (28.5 KB) - added by TheLastLovemark 15 months ago.
python37_config.log (756.0 KB) - added by TheLastLovemark 15 months ago.

Download all attachments as: .zip

Change History (16)

Changed 15 months ago by TheLastLovemark

Attachment: python37_main.log added

Changed 15 months ago by TheLastLovemark

Attachment: sslscan_main.log added

comment:1 Changed 15 months ago by jmroot (Joshua Root)

Owner: set to jmroot
Port: openssl wireshark3 removed
Status: newaccepted
Summary: trying to install or upgrade anything dependent on openssl failspython37 @3.7.4_1+optimizations build failure

The sslscan build failure is #58971. This one can be about python37 (which doesn't seem to be failing for any reason related to openssl).

Last edited 15 months ago by jmroot (Joshua Root) (previous) (diff)

comment:2 Changed 15 months ago by jmroot (Joshua Root)

I can't reproduce this on 10.14. Could you please attach the file config.log from python37's work directory?

comment:3 Changed 15 months ago by TheLastLovemark

I'm on running MP 2.5.4 on macos 10.13.6

Changed 15 months ago by TheLastLovemark

Attachment: python37_config.log added

comment:4 Changed 15 months ago by jmroot (Joshua Root)

Do you have a util.h in /opt/local/include or /usr/local/include?

comment:5 Changed 15 months ago by TheLastLovemark

/opt/local/include/util.h <--YES

/usr/local/include/util.h <--NO, no include folder here at all.

/usr/include/util.h <--YES

Last edited 15 months ago by TheLastLovemark (previous) (diff)

comment:6 Changed 15 months ago by jmroot (Joshua Root)

So /opt/local/include/util.h is almost certainly the problem. Which port installed it?

comment:7 Changed 15 months ago by TheLastLovemark

not sure, how do I find out?

comment:8 in reply to:  7 Changed 15 months ago by iEFdev

Replying to TheLastLovemark:

not sure, how do I find out?

Try with:

port provides /opt/local/include/util.h

comment:9 Changed 15 months ago by TheLastLovemark

$ port provides /opt/local/include/util.h
/opt/local/include/util.h is provided by: libpftputil

comment:10 Changed 15 months ago by jmroot (Joshua Root)

Port: libpftputil added
Summary: python37 @3.7.4_1+optimizations build failurelibpftputil should not install util.h, shadows /usr/include/util.h

comment:11 Changed 15 months ago by jmroot (Joshua Root)

If you deactivate libpftputil then you should be able to build python37.

comment:12 Changed 15 months ago by jmroot (Joshua Root)

Resolution: fixed
Status: acceptedclosed

In 8a36d9b7533001638fe36973cc613f38ecf330f6/macports-ports (master):

libpftputil: install headers in a subdir

Several of the headers have very generic names, including util.h which
shadowed the one in /usr/include causing anything that needed the
standard one to fail to build.

Fixes: #59031

comment:13 Changed 15 months ago by TheLastLovemark

I think it worked. I also had a number of broken ports and they are currently rebuilding

Note: See TracTickets for help on using tickets.