Opened 6 months ago

Last modified 4 weeks ago

#59161 assigned defect

gnuplot @5.2.7_0+aquaterm+luaterm+pangocairo+wxwidgets+x11: dyld: Symbol not found: __ZTISt12length_error

Reported by: hawkins-github Owned by: mojca (Mojca Miklavec)
Priority: Normal Milestone:
Component: ports Version: 2.6.1
Keywords: mojave Cc:
Port: gnuplot

Description

Hello,

Following a new install of Xcode (Xcode 11.0 Build version 11A420a), selfupdate (MacPorts base version 2.6.1), and a new install of gnuplot on macOS Mojave 10.14.6, my attempt to run gnuplot gives the following:

$ gnuplot
dyld: Symbol not found: __ZTISt12length_error
  Referenced from: /opt/local/bin/gnuplot
  Expected in: /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox
 in /opt/local/bin/gnuplot
Abort trap: 6
$

Since the installs and updates went smoothly it is unclear how I should proceed to resolve this issue. Your help with this would be greatly appreciated.

Change History (4)

comment:1 Changed 6 months ago by kencu (Ken)

this looks related <https://stackoverflow.com/questions/56455562/xcode-11-beta-simulator-crashes-when-trying-to-load-audiotoolbox>.

Some symbols in AudioToolbox were apparently not supposed to be exported.

comment:2 Changed 6 months ago by jmroot (Joshua Root)

Cc: mojca@… removed
Owner: set to mojca
Status: newassigned

comment:3 Changed 6 months ago by mojca (Mojca Miklavec)

While you may have assigned the ticket to me, I have absolutely no idea what to do about it, in particular if it's a problem with the macOS development toolchain (I did not yet switch to anything beyond 10.13).

comment:4 Changed 4 weeks ago by ryandesign (Ryan Schmidt)

Keywords: mojave added

See also #60179, the same problem about another port. Try my advice there (upgrade to Xcode 11.2.1 or downgrade to Xcode 10).

Note: See TracTickets for help on using tickets.