Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#59227 closed defect (duplicate)

commit 9e40a5a compiler_blacklist_versions pg breaks Portfile build(s)

Reported by: TP75 Owned by:
Priority: Normal Milestone:
Component: base Version: 2.6.1
Keywords: Cc: dbevans (David B. Evans), jmroot (Joshua Root)
Port: libvpx

Description

The recent update of ' macports-ports/_resources/port1.0/group/compiler_blacklist_versions-1.0.tcl ' leads to issues.

jmroot: This does remove support for blacklisting particular versions of apple-gcc-4.2, but nothing in the tree uses that, and nor should it really.

Unfortunately, this breaks 'GIMP2' and especially 'libvpx' builds.

Error: Unable to open port: invalid command name "compiler_blacklist_versions._get_compiler_version"

see comment on commit 9e40a5a "compiler_blacklist_versions pg: use base support"

[...]
DEBUG: epoch: in tree: 0 installed: 0
DEBUG: libvpx 1.8.1_0 exists in the ports tree
DEBUG: libvpx 1.8.1_0  is the latest installed
DEBUG: libvpx 1.8.1_0  is active
DEBUG: Merging existing variants '' into variants
DEBUG: new fully merged portvariants: 
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/macports/release/tarballs/ports/multimedia/libvpx
DEBUG: OS darwin/18.7.0 (macOS 10.14) arch i386
DEBUG: Sourcing PortGroup compiler_blacklist_versions 1.0 from /opt/local/var/macports/sources/rsync.macports.org/macports/release/tarballs/ports/_resources/port1.0/group/compiler_blacklist_versions-1.0.tcl
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/macports/release/tarballs/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: Sourcing PortGroup muniversal 1.0 from /opt/local/var/macports/sources/rsync.macports.org/macports/release/tarballs/ports/_resources/port1.0/group/muniversal-1.0.tcl
DEBUG: compiler clang 1100.0.33.8 not blacklisted because it doesn't match {clang < 800}
DEBUG: invalid command name "compiler_blacklist_versions._get_compiler_version"
    while executing
"compiler_blacklist_versions._get_compiler_version ${configure.compiler}"
    invoked from within
"if {[string match {macports-clang-3.[5-9]} ${configure.compiler}] ||
    [string match {macports-clang-[4-9].*} ${configure.compiler}] ||
    [string ..."
    (file "Portfile" line 96)
    invoked from within
"source Portfile"
    invoked from within
"$workername eval {source Portfile}"
    (procedure "mportopen" line 50)
    invoked from within
"mportopen $porturl [array get interp_options] [array get variations]"
Error: Unable to open port: invalid command name "compiler_blacklist_versions._get_compiler_version"
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

Please note the error leads to hassle in handling the 'libpvx' Portfile with usual 'port' commands in addition to the a.m. failure.

Hope this helps.

Change History (3)

comment:1 Changed 14 months ago by mf2k (Frank Schima)

Port: port1.0 removed

comment:2 Changed 14 months ago by mf2k (Frank Schima)

Resolution: duplicate
Status: newclosed

Duplicate of #59226.

comment:3 Changed 14 months ago by TP75

This may be a duplicate of #59226 but includes details on the MacPorts 'base' and the apparent core issue.

Furthermore, as a hotfix workaround one may compile 'libvpx' after establishing a local Portfile definition and commenting out the follwing lines in the deviated Portfile as follows:

#if {[string match {macports-clang-3.[5-9]} ${configure.compiler}] ||
#    [string match {macports-clang-[4-9].*} ${configure.compiler}] ||
#    [string match {macports-clang-[1-9][0-9].*} ${configure.compiler}] ||
#    (${configure.compiler} eq "clang" && [compiler_blacklist_versions._get_compiler_version ${configure.compiler}] > 602)} {
#        build.args-append CFLAGS_S=-fno-integrated-as
#}

Please note this is an unofficial hotfix and is at one's sole risk. At least this works for 'libvpx' in the a.m. environment.

Note: See TracTickets for help on using tickets.