#59236 closed defect (duplicate)

Problem update poppler

Reported by: alain2566 Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.1
Keywords: Cc: dbevans (David B. Evans)
Port: poppler

Description (last modified by kencu (Ken))

Hi, I am not a pro of computer sciences but I use latex, gimp, gnuplot on Mac Mini. I use macports since long time and offently the same problem appears : error due to the update for poppler. My install is very clean : 3 or 4 times in the week I make the update. I work with Mac MINI last generation / mojave 10.14.6. Many thanks for your help. Alain. PS : In the following are the command/message taht can be useful.

su root
Password:
sh-3.2# port selfupdate
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.6.1 installed,
MacPorts base version 2.6.1 downloaded.
--->  Updating the ports tree
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated
sh-3.2# port upgrade outdated
--->  Fetching archive for graphite2
--->  Attempting to fetch graphite2-1.3.13_1.darwin_18.x86_64.tbz2 from http://lil.fr.packages.macports.org/graphite2
--->  Attempting to fetch graphite2-1.3.13_1.darwin_18.x86_64.tbz2.rmd160 from http://lil.fr.packages.macports.org/graphite2
--->  Installing graphite2 @1.3.13_1
--->  Cleaning graphite2
--->  Deactivating graphite2 @1.3.13_0
--->  Cleaning graphite2
--->  Activating graphite2 @1.3.13_1
--->  Cleaning graphite2
--->  Computing dependencies for poppler
--->  Fetching archive for poppler
--->  Attempting to fetch poppler-0.81.0_0.darwin_18.x86_64.tbz2 from http://lil.fr.packages.macports.org/poppler
--->  Attempting to fetch poppler-0.81.0_0.darwin_18.x86_64.tbz2 from https://packages.macports.org/poppler
--->  Attempting to fetch poppler-0.81.0_0.darwin_18.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/poppler
--->  Building poppler
Error: Failed to build poppler: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_poppler/poppler/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

sh-3.2#

Attachments (1)

main.log (856.8 KB) - added by cctile (Charles Choi) 14 months ago.
poppler 0.81 main.log

Download all attachments as: .zip

Change History (6)

comment:1 Changed 14 months ago by cctile (Charles Choi)

Also seeing this issue with port 2.6.1

--->  Building poppler
Error: Failed to build poppler: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_poppler/poppler/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port poppler failed

Attaching main.log

Changed 14 months ago by cctile (Charles Choi)

Attachment: main.log added

poppler 0.81 main.log

comment:2 Changed 14 months ago by kencu (Ken)

Description: modified (diff)

comment:3 Changed 14 months ago by kencu (Ken)

:info:build clang: warning: no such sysroot directory: '/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk' [-Wmissing-sysroot]

comment:4 Changed 14 months ago by kencu (Ken)

please consider doing this 59196#comment:6 and you should be good to go.

comment:5 Changed 14 months ago by jmroot (Joshua Root)

Cc: dbevans added
Keywords: port upgrade outdated removed
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.