#59252 closed defect (invalid)

Python27 has Linking issues with Xcode 11.1 and MacOS Catalina 10.15

Reported by: IComplainInComments Owned by: jmroot (Joshua Root)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: python27

Description

Python27 fails to stage into the destroot. After looking through the logs its seems ld is missing symbols for the x86_64 arch ld: symbol(s) not found for architecture x86_64 . Building after port cleaning, and rebuilding without cleaning gives the same result.

Here is a log snippet of where it gets funky

:info:destroot if ! DYLD_FRAMEWORK_PATH=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_python27/python27/work/Python-2.7.16  ../python.exe \
:info:destroot 			-c 'import EasyDialogs' 2>/dev/null ; then \
:info:destroot 		echo "EasyDialogs not available in this Python - skipping Build Applet.app" ; \
:info:destroot 	else \
:info:destroot 		DYLD_FRAMEWORK_PATH=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_python27/python27/work/Python-2.7.16  ../python.exe ./scripts/BuildApplet.py \
:info:destroot 			--destroot "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_python27/python27/work/destroot" \
:info:destroot 			--python=/opt/local/Library/Frameworks/Python.framework/Versions/2.7/Resources/Python.app/Contents/MacOS/Python \
:info:destroot 			--output "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_python27/python27/work/destroot/Applications/MacPorts/Python 2.7/Build Applet.app" \
:info:destroot 			./scripts/BuildApplet.py && \
:info:destroot 		if [ -n "" ] ; then \
:info:destroot 			rm "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_python27/python27/work/destroot/Applications/MacPorts/Python 2.7/Build Applet.app/Contents/MacOS/Python" && \
:info:destroot 			lipo  \
:info:destroot 				-output "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_python27/python27/work/destroot/Applications/MacPorts/Python 2.7/Build Applet.app/Contents/MacOS/Python" \
:info:destroot 				../python.exe ; \
:info:destroot 		fi \
:info:destroot 	fi
:info:destroot EasyDialogs not available in this Python - skipping Build Applet.app
:info:destroot cd PythonLauncher && make install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_python27/python27/work/destroot
:info:destroot make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_python27/python27/work/Python-2.7.16/Mac/PythonLauncher'
:info:destroot /usr/bin/clang -L/opt/local/lib -Wl,-headerpad_max_install_names -L/opt/local/lib/db48 -Wl,-syslibroot,/Library/Developer/CommandLineTools/SDKs/MacOSX10.14.sdk -arch x86_64 -o "Python Launcher" FileSettings.o MyAppDelegate.o MyDocument.o PreferencesWindowController.o doscript.o main.o -framework AppKit -framework Carbon
:info:destroot Undefined symbols for architecture x86_64:
:info:destroot   "_objc_opt_new", referenced from:
:info:destroot       +[FileSettings getFactorySettingsForFileType:] in FileSettings.o
:info:destroot       +[FileSettings getDefaultsForFileType:] in FileSettings.o
:info:destroot       +[FileSettings newSettingsForFileType:] in FileSettings.o
:info:destroot ld: symbol(s) not found for architecture x86_64
:info:destroot clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:destroot make[2]: *** [Python Launcher] Error 1
:info:destroot make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_python27/python27/work/Python-2.7.16/Mac/PythonLauncher'
:info:destroot make[1]: *** [install_PythonLauncher] Error 2
:info:destroot make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_python27/python27/work/Python-2.7.16/Mac'
:info:destroot make: *** [frameworkinstallapps] Error 2
:info:destroot make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_python27/python27/work/Python-2.7.16'
:info:destroot Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_python27/python27/work/Python-2.7.16" && /usr/bin/make -w frameworkinstall maninstall DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_python27/python27/work/destroot 
:info:destroot Exit code: 2
:error:destroot Failed to destroot python27: command execution failed
:debug:destroot Error code: CHILDSTATUS 3482 2
:debug:destroot Backtrace: command execution failed
:debug:destroot     while executing
:debug:destroot "system {*}$notty {*}$nice $fullcmdstring"
:debug:destroot     invoked from within
:debug:destroot "command_exec destroot"
:debug:destroot     (procedure "portdestroot::destroot_main" line 2)
:debug:destroot     invoked from within
:debug:destroot "$procedure $targetname"
:error:destroot See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_python27/python27/main.log for details.

Attachments (1)

main.log.xz (49.3 KB) - added by IComplainInComments 14 months ago.
python27 build log

Download all attachments as: .zip

Change History (9)

Changed 14 months ago by IComplainInComments

Attachment: main.log.xz added

python27 build log

comment:1 Changed 14 months ago by mf2k (Frank Schima)

Milestone: MacPorts 2.7.0

The Milestone field is for use by Macports team members only, please do not set it.

comment:2 Changed 14 months ago by mf2k (Frank Schima)

Cc: jmroot removed
Keywords: python27 destroot ld linker removed
Owner: set to jmroot
Status: newassigned

comment:3 Changed 14 months ago by jmroot (Joshua Root)

Any idea if this has been reported upstream?

comment:4 in reply to:  3 Changed 14 months ago by IComplainInComments

Replying to jmroot:

Any idea if this has been reported upstream?

For Python? Looking on the github and python ticket tracker, no.

comment:5 Changed 14 months ago by jmroot (Joshua Root)

I'm not able to reproduce this. Why are you using the 10.14 SDK on 10.15?

comment:6 in reply to:  5 Changed 14 months ago by IComplainInComments

Replying to jmroot:

I'm not able to reproduce this. Why are you using the 10.14 SDK on 10.15?

For the love of GOD! Why is xcode on 10.14 SDK? Let me switch to 10.15, and ill let you know if it fixes it...

comment:7 in reply to:  5 Changed 14 months ago by IComplainInComments

Replying to jmroot:

I'm not able to reproduce this. Why are you using the 10.14 SDK on 10.15?

It built, sorry for all the commotion...

comment:8 Changed 14 months ago by jmroot (Joshua Root)

Resolution: invalid
Status: assignedclosed

OK, thanks for the confirmation.

Note: See TracTickets for help on using tickets.