Opened 2 months ago

Last modified 7 weeks ago

#59255 assigned defect

syncthing: fails to build under catalina

Reported by: Knapoc Owned by: lbschenkel (Leonardo Brondani Schenkel)
Priority: Normal Milestone:
Component: ports Version: 2.6.1
Keywords: Cc:
Port: syncthing

Description (last modified by Knapoc)

I tried to install synching under Catalina. The dependencies (go) install just fine, but syncthing fails with the following message:

:info:build Command failed: cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_net_syncthing/syncthing/work/gopath/src/github.com/syncthing/syncthing" && /opt/local/bin/go run build.go -version v1.3.0 -no-upgrade install syncthing

The full log is attached.

Attachments (1)

main.log (25.8 KB) - added by Knapoc 2 months ago.
build log

Download all attachments as: .zip

Change History (12)

Changed 2 months ago by Knapoc

Attachment: main.log added

build log

comment:1 Changed 2 months ago by Knapoc

Description: modified (diff)

comment:2 Changed 2 months ago by lbschenkel (Leonardo Brondani Schenkel)

Unfortunately I don't have a Catalina system available and won't have one in the foreseeable future, so that complicates my life a bit for a ticket like this.

My guesses are that this link failure during build could be one of 2 things:

  1. The problem is indeed in syncthing, it runs link in a custom way during the build and this broke with the new tooling in Catalina
  2. The problem is actually in the go port, syncthing does not do anything custom but go "build system" broke in Catalina, also due to changes of tooling

I'm busy right now and I can't look at this in detail, but this weekend I'll try to check upstream to see if there are any mentions of stuff like this. Hopefully, in either case, there'll be an upstream fix or release soon that we can incorporate to get this fixed downstream.

In case you feel inclined to do the same research in the upstream projects and share it here, I would appreciate that very much as well.

comment:3 Changed 8 weeks ago by jonasjonas (Frank Hellenkamp)

Interestingly:

I reinstalled all my ports under Catalina (syncthing being one of them) and the build and install went fine and it seems to be running smoothly...

Did you reinstall all ports?

comment:4 Changed 8 weeks ago by lbschenkel (Leonardo Brondani Schenkel)

That's indeed interesting. I have done some quick search in the upstream projects this weekend and I saw no similar reports.

Knapoc, can you further elaborate on your set-up?

  • do you have the Catalina command-line tools installed?
  • what version of Xcode?
  • are you installing syncthing and/or go for the first time under Catalina, or is this a reinstallation due to an in-place macOS upgrade?
  • what version of MacPorts? have you run sudo port selfupdate recently?

comment:5 Changed 8 weeks ago by mf2k (Frank Schima)

Cc: lbschenkel removed
Owner: set to lbschenkel
Status: newassigned

comment:6 Changed 8 weeks ago by Knapoc

I followed the migration guide when I upgraded. So as soon as I upgraded macOS and MacPorts I uninstalled all ports and tried to build them again. I'm running Xcode 11.1 and xcode-select version 2370. My MacPorts version is 2.6.1 with the newest builds.

I try to clean Xcode and MacPorts and will update this comment later.

edit: still no luck after reinstalling MacPorts and Xcode.

Last edited 8 weeks ago by Knapoc (previous) (diff)

comment:7 Changed 7 weeks ago by lbschenkel (Leonardo Brondani Schenkel)

Thank you for the additional info.

I know it is frustrating, but unfortunately I don't think I can troubleshoot or fix this at this point. We don't have Travis CI builders for Catalina yet, so I cannot test any changes by submitting PRs to GitHub either. Maybe if we are lucky, another MacPorts member who has upgraded to Catalina can help.

I will keep an eye on the bug trackers of upstream projects and maybe I will stumble upon any clues. When we start having Catalina CI workers, or if I get access to Catalina by other means, then I'll try to do further investigation.

comment:8 Changed 7 weeks ago by Knapoc

It seemed to be an issue with version detection and/or my hostname. I had also issues with building perl5.28 and thought to give Mojca's assumptions/findings from #58572 a try. As soon as I changed the hostname to one without spaces, building syncthing was successful. Guess this should be reported upstream?

Last edited 7 weeks ago by Knapoc (previous) (diff)

comment:9 Changed 7 weeks ago by lbschenkel (Leonardo Brondani Schenkel)

Wow, this is definitely something I would not have guessed.

Do you mind reporting that to Syncthing yourself? It's because you have all the info regarding your particulars, and it seems that I would be an unnecessary middle man in this process. If you link it here I'll watch over it and if there's anything I can chime in about, I will.

comment:10 Changed 7 weeks ago by Knapoc

here you go: syncthing#6095

comment:11 Changed 7 weeks ago by lbschenkel (Leonardo Brondani Schenkel)

Great, thank you. Fine investigation work, by the way. I'm glad that you found out what the problem was.

Note: See TracTickets for help on using tickets.