#59259 closed defect (duplicate)

librsvg-2.44.14_0: error when compiling inkscape on mac os x catalina

Reported by: juandavm (Juan Daniel) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.6.1
Keywords: Cc:
Port: librsvg

Description (last modified by Schamschula (Marius Schamschula))

Rrror when compiling inkscape on mac os x catalina:

--->  Fetching archive for librsvg
--->  Attempting to fetch librsvg-2.44.14_0.darwin_19.x86_64.tbz2 from http://lil.fr.packages.macports.org/librsvg
--->  Attempting to fetch librsvg-2.44.14_0.darwin_19.x86_64.tbz2 from https://packages.macports.org/librsvg
--->  Attempting to fetch librsvg-2.44.14_0.darwin_19.x86_64.tbz2 from http://nue.de.packages.macports.org/librsvg
--->  Fetching distfiles for librsvg
--->  Verifying checksums for librsvg
--->  Extracting librsvg
--->  Applying patches to librsvg
--->  Configuring librsvg
--->  Building librsvg
Error: Failed to build librsvg: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port inkscape failed

Attachments (2)

main.log (222.4 KB) - added by juandavm (Juan Daniel) 14 months ago.
Log
librsvg.diff (7.7 KB) - added by stromnov (Andrew Stromnov) 14 months ago.
working patch

Download all attachments as: .zip

Change History (6)

Changed 14 months ago by juandavm (Juan Daniel)

Attachment: main.log added

Log

comment:1 Changed 14 months ago by Schamschula (Marius Schamschula)

Description: modified (diff)

Please use wiki formatting!

comment:2 Changed 14 months ago by mf2k (Frank Schima)

Port: inkscape removed

comment:3 Changed 14 months ago by mf2k (Frank Schima)

Owner: set to dbevans
Status: newassigned

In the future, please add the port maintainer(s) to Cc (port info --maintainers librsvg), if any.

comment:4 Changed 14 months ago by mf2k (Frank Schima)

Resolution: duplicate
Status: assignedclosed

Duplicate of #59244.

Changed 14 months ago by stromnov (Andrew Stromnov)

Attachment: librsvg.diff added

working patch

Note: See TracTickets for help on using tickets.