#59274 closed defect (duplicate)

librsvg-2.44.14_0.darwin_19 build error on macOS Catalina 14.15

Reported by: abaldoni Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: librsvg

Description

librsvg-2.44.14 cannot be built on macOS Catalina 14.15 due to the following compilation error

:info:build      Running `rustc --crate-name cssparser /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/work/librsvg-2.44.14/vendor/cssparser/src/lib.rs --color never --crate-type lib --emit=dep-info,metadata,link -C opt-level=3 -C debuginfo=2 -C metadata=eb3966de069cf136 -C extra-filename=-eb3966de069cf136 --out-dir /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/work/librsvg-2.44.14/target/x86_64-apple-darwin/release/deps --target x86_64-apple-darwin -L dependency=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/work/librsvg-2.44.14/target/x86_64-apple-darwin/release/deps -L dependency=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/work/librsvg-2.44.14/target/release/deps --extern cssparser_macros=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/work/librsvg-2.44.14/target/release/deps/libcssparser_macros-8af80573d96eb99e.dylib --extern dtoa_short=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/work/librsvg-2.44.14/target/x86_64-apple-darwin/release/deps/libdtoa_short-7a1e9c5a75c55118.rlib --extern itoa=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/work/librsvg-2.44.14/target/x86_64-apple-darwin/release/deps/libitoa-c439eb5e9843bb0e.rlib --extern matches=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/work/librsvg-2.44.14/target/x86_64-apple-darwin/release/deps/libmatches-9a4b985fa287e421.rlib --extern phf=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/work/librsvg-2.44.14/target/x86_64-apple-darwin/release/deps/libphf-699c46e1587ae37c.rlib --extern procedural_masquerade=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/work/librsvg-2.44.14/target/x86_64-apple-darwin/release/deps/libprocedural_masquerade-6fdca77c73bc2d55.rlib --extern smallvec=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/work/librsvg-2.44.14/target/x86_64-apple-darwin/release/deps/libsmallvec-d97d88c36742156d.rlib --cap-lints allow -C linker=/usr/bin/clang --cfg rustc_has_pr45225`
:info:build error[E0506]: cannot assign to `self.input.cached_token` because it is borrowed
:info:build    --> /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/work/librsvg-2.44.14/vendor/cssparser/src/parser.rs:572:17
:info:build     |
:info:build 547 |     pub fn next_including_whitespace_and_comments(&mut self) -> Result<&Token<'i>, BasicParseError<'i>> {
:info:build     |                                                   - let's call the lifetime of this reference `'1`
:info:build ...
:info:build 560 |             Some(ref cached_token)
:info:build     |                  ---------------- borrow of `self.input.cached_token` occurs here
:info:build ...
:info:build 572 |                 self.input.cached_token = Some(CachedToken {
:info:build     |                 ^^^^^^^^^^^^^^^^^^^^^^^ assignment to borrowed `self.input.cached_token` occurs here
:info:build ...
:info:build 584 |         Ok(token)
:info:build     |         --------- returning this value requires that `self.input.cached_token.0` is borrowed for `'1`
:info:build error: aborting due to previous error
:info:build For more information about this error, try `rustc --explain E0506`.
:info:build error: Could not compile `cssparser`.
:info:build Caused by:
:info:build   process didn't exit successfully: `rustc --crate-name cssparser /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_librsvg/librsvg/work/librsvg-2.44.14/vendor/cssparser/src/lib.rs --color never --crate-type lib --emit=dep-info,metadata,link -C opt-level=3 -C debuginfo=2 -C metadata=eb3966de069cf136 -C extra-filename=-eb3966de069cf136 --out-dir /opt/local/var/macports/build/

The installaed version of rust is 1.38.0

Change History (1)

comment:1 Changed 14 months ago by jmroot (Joshua Root)

Port: librsvg added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.