Opened 12 months ago

Closed 10 months ago

Last modified 10 months ago

#59490 closed defect (worksforme)

nodejs10 @10.16.3_0: unable to upgrade to 10.17.0_0

Reported by: thomasrussellmurphy (Thomas Russell Murphy) Owned by: ci42
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc: pturley0
Port: nodejs10

Description

$ sudo port upgrade nodejs10
--->  Computing dependencies for nodejs10
--->  Fetching archive for nodejs10
--->  Attempting to fetch nodejs10-10.17.0_0.darwin_18.x86_64.tbz2 from http://ywg.ca.packages.macports.org/mirror/macports/packages/nodejs10
--->  Attempting to fetch nodejs10-10.17.0_0.darwin_18.x86_64.tbz2 from https://packages.macports.org/nodejs10
--->  Attempting to fetch nodejs10-10.17.0_0.darwin_18.x86_64.tbz2 from http://aus.us.packages.macports.org/macports/packages/nodejs10
--->  Fetching distfiles for nodejs10
--->  Verifying checksums for nodejs10
--->  Extracting nodejs10
--->  Applying patches to nodejs10
--->  Configuring nodejs10
--->  Building nodejs10
Error: Failed to build nodejs10: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_nodejs10/nodejs10/main.log for details.

Failure experienced from upgrade and uninstall -f+install.

Attachments (2)

nodejs10_10.17.0_0_failure.log.gz (26.8 KB) - added by thomasrussellmurphy (Thomas Russell Murphy) 12 months ago.
build failure log, gzip'd due to raw size ~1MB
m_eisenberg_2019-12-19_nodejs10_main.log (633.5 KB) - added by murrayE 10 months ago.
main.log for nodejs10-10.18.0_0 failed configure on update - Murray Eisenberg - 2019-12-19

Download all attachments as: .zip

Change History (14)

Changed 12 months ago by thomasrussellmurphy (Thomas Russell Murphy)

build failure log, gzip'd due to raw size ~1MB

comment:1 Changed 12 months ago by mf2k (Frank Schima)

Cc: ciserlohn@… removed
Owner: set to ci42
Status: newassigned

comment:2 Changed 12 months ago by ryandesign (Ryan Schmidt)

The log says the problem is:

:info:build ld: unexpected token: !tapi-tbd-v3 file '/Library/Developer/CommandLineTools/SDKs/MacOSX10.14.sdk/usr/lib/libSystem.tbd' for architecture x86_64

Since you're using Xcode 11, try installing ld64 with the +ld64_xcode variant and cctools with the +xcode variant. (The versions of the software that the ports install without those variants are not compatible with Xcode 11 or later yet.)

comment:3 Changed 12 months ago by thomasrussellmurphy (Thomas Russell Murphy)

The solution from #59376 and recommended above appears to have enabled me to reinstall nodejs10:

sudo port -f uninstall ld64
sudo port install ld64 +ld64_xcode

I did not need to change my cctools variant, though I am about to.

comment:4 Changed 12 months ago by pturley0

Cc: pturley0 added

comment:5 Changed 10 months ago by murrayE

The alleged work-around of uninstalling ld64, then installing it as "install ld64 +ld64_xcode" did NOT work for me: the configure failed. From the log:

:info:configure     python tools/gyp_node.py --no-parallel -f make-mac
:info:configure Error running GYP
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_nodejs10/nodejs10/work/node-v10.18.0" && ./configure --prefix=/opt/local --without-npm --with-intl=system-icu --shared-openssl --shared-openssl-includes=/opt/local/include/openssl --shared-openssl-libpath=/opt/local/lib --dest-cpu=x64 
Last edited 10 months ago by murrayE (previous) (diff)

comment:6 Changed 10 months ago by kencu (Ken)

Well, nobody promises there will only be one issue. The ld64 issue had to be fixed -- if you fixed that, and now have a new issue, welcome to the world of software installation.

You probably already know this, but without a new log showing us what went wrong in your build, we have no hope of helping you. The small bit you copy-pasted is not enough to guess.

Last edited 10 months ago by kencu (Ken) (previous) (diff)

Changed 10 months ago by murrayE

main.log for nodejs10-10.18.0_0 failed configure on update - Murray Eisenberg - 2019-12-19

comment:7 Changed 10 months ago by kencu (Ken)

This part looks to need some investigation:

:info:configure gyp: No Xcode or CLT version detected!

comment:8 Changed 10 months ago by gcs-github (Guillaume Ceccarelli)

I stumbled upon the same error:

:info:configure gyp: No Xcode or CLT version detected!

with every other port installing / upgrading fine, and with developer tools installed (my macports.conf is set up with buildfromsource always).

What fixed it for me was to manually download and re-install the XCode Command Line Tools DMG from developer.apple.com. I do not know whether the problem is related to the original command line tools auto-installed from xcode-select or if it is related to having updated XCode between the original installation of the CLT and my attempt at upgrading nodejs10.

comment:9 Changed 10 months ago by murrayE

Aha: I opened Xcode 11.3 under Catalina 10.15.2 and it said it wanted to "install additional components", which I let it do. After that, upgrading nodejs10 @10.18.0_0 worked OK.

comment:10 Changed 10 months ago by gcs-github (Guillaume Ceccarelli)

That's good! In my case, the additional components were installed. XCode was done trying to install anything after opening the IDE, and, again, other ports compiled fine. So there's probably still something fishy going on.

comment:11 Changed 10 months ago by kencu (Ken)

Resolution: worksforme
Status: assignedclosed

comment:12 Changed 10 months ago by kencu (Ken)

Whatever it is, it doesn't seem related to nodejs10 directly...

Note: See TracTickets for help on using tickets.