Opened 3 years ago

Closed 3 years ago

#59509 closed defect (duplicate)

py37-pyqt5: Failed to determine the detail of your Qt installation (Xcode 11, macOS 10.14)

Reported by: mfacorcoran Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: randawg, tehcog (tehcog)
Port: py-pyqt5

Description

py37-pyqt5 fails to build - the error in the log file seems to be

:info:configure Error: Failed to determine the detail of your Qt installation. Try again using
:info:configure the --verbose flag to see more detail about the problem.
:info:configure Querying qmake about your Qt installation...
:info:configure Determining the details of your Qt installation...
:info:configure /opt/local/libexec/qt5/bin/qmake -o cfgtest_QtCore.mk cfgtest_QtCore.pro
:info:configure Project ERROR: Could not resolve SDK Path for 'macosx10.14' using --show-sdk-path

so perhaps this has to do with the change in the SDK path in Xcode 11? I've got MacOSX10.14.sdk linked as:

/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk -> /Library/Developer/CommandLineTools/SDKs/MacOSX10.14.sdk

but that doesn't seem to help. I've attached the log file for completeness

Attachments (1)

main.log (109.2 KB) - added by mfacorcoran 3 years ago.
log file from build of py37-pyqt5

Download all attachments as: .zip

Change History (12)

Changed 3 years ago by mfacorcoran

Attachment: main.log added

log file from build of py37-pyqt5

comment:1 Changed 3 years ago by jmroot (Joshua Root)

Owner: set to mamoll
Port: py-pyqt5 added
Status: newassigned

comment:2 Changed 3 years ago by randawg

Cc: randawg added

comment:3 Changed 3 years ago by randawg

Anyone know of a way to manually tell it where to find the new SDK location as a workaround?

comment:4 Changed 3 years ago by mamoll (Mark Moll)

comment:5 in reply to:  4 Changed 3 years ago by mfacorcoran

Replying to mamoll:

Does installing the Xcode 11 Command Line Tools (https://download.developer.apple.com/Developer_Tools/Command_Line_Tools_for_Xcode_11/Command_Line_Tools_for_Xcode_11.dmg) fix the problem?

I've already got XCode 11 and the command line tools installed:

% xcode-select --install
xcode-select: error: command line tools are already installed, use "Software Update" to install updates

I tried to re-install them from

https://download.developer.apple.com/Developer_Tools/Command_Line_Tools_for_Xcode_11/Command_Line_Tools_for_Xcode_11.dmg

but that link didn't work for me...

comment:6 in reply to:  4 Changed 3 years ago by randawg

Replying to mamoll:

Does installing the Xcode 11 Command Line Tools (https://download.developer.apple.com/Developer_Tools/Command_Line_Tools_for_Xcode_11/Command_Line_Tools_for_Xcode_11.dmg) fix the problem?

Thanks for the suggestion. I downloaded the Xcode 11 command line tools from Apple and re-installed them, but when I try to install py37-pyqt5 the same error persists.

comment:7 Changed 3 years ago by tehcog (tehcog)

Cc: tehcog added

comment:8 Changed 3 years ago by tehcog (tehcog)

Having similar configuration issue on mavericks: py37-pyqt5

:info:configure Error: Failed to determine the detail of your Qt installation. Try again using
:info:configure the --verbose flag to see more detail about the problem.
:info:configure Querying qmake about your Qt installation...
:info:configure Determining the details of your Qt installation...
:info:configure /opt/local/libexec/qt5/bin/qmake -o cfgtest_QtCore.mk cfgtest_QtCore.pro
:info:configure Info: creating stash file /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-pyqt5/py37-pyqt5/work/PyQt5_gpl-5.13.1/.qmake.stash
:info:configure make -f cfgtest_QtCore.mk
:info:configure /Applications/Utilities/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -c -pipe -stdlib=libc++ -arch x86_64 -isysroot /Applications/Utilities/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk -mmacosx-version-min=10.9  -Os -Wall -W -fPIC -DQT_NO_DEBUG -DQT_CORE_LIB -I. -I/opt/local/libexec/qt5/lib/QtCore.framework/Headers -I. -I/opt/local/libexec/qt5/mkspecs/macx-clang -F/opt/local/libexec/qt5/lib -o cfgtest_QtCore.o config-tests/cfgtest_QtCore.cpp
:info:configure In file included from config-tests/cfgtest_QtCore.cpp:1:
:info:configure In file included from /opt/local/libexec/qt5/lib/QtCore.framework/Headers/QCoreApplication:1:
:info:configure In file included from /opt/local/libexec/qt5/lib/QtCore.framework/Headers/qcoreapplication.h:43:
:info:configure In file included from /opt/local/libexec/qt5/lib/QtCore.framework/Headers/qglobal.h:97:
:info:configure /opt/local/libexec/qt5/lib/QtCore.framework/Headers/qcompilerdetection.h:562:6: error: Qt requires a C++11 compiler and yours does not seem to be that.
:info:configure #    error Qt requires a C++11 compiler and yours does not seem to be that.
:info:configure      ^

comment:9 Changed 3 years ago by randawg

Can anyone tell me the versions of macOS or Xcode on which pyqt5 will still build successfully? I am still getting the above error on macOX 10.14.6 and Xcode 11.3.1. I have some dependent ports which have been updated and I can no longer run them, so if its as simple as going to a different version of Xcode or upgrading to Catalina I will try that. Thanks!

comment:10 Changed 3 years ago by mf2k (Frank Schima)

Owner: mamoll deleted

comment:11 Changed 3 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: assignedclosed

Duplicate of #58760.

Note: See TracTickets for help on using tickets.