Opened 15 years ago

Closed 15 years ago

Last modified 5 years ago

#5958 closed enhancement (duplicate)

Update xorg Portfile for Tiger

Reported by: michael_six@… Owned by: waqar@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port: xorg

Description (last modified by ryandesign (Ryan Schmidt))

UPDATE xorg

I have included a fink patch in this xorg Portfile for the xorg compilation. I just hacked this out without much understanding of the process, so it may need to be cleaned up.

My Thoughts on This

I would like to implement some sort of way to force the Portfile to use gcc 3.3 in Darwin_8 (macosx) I don't know that gcc 4 is available on pure darwin or not. anyways, I have been told that xorg does not build right in Tiger with gcc 4, however I built this both with gcc 3.3 and gcc 4 and I don't notice much of a difference other than the one I built with gcc-3.3 seemed to run faster.

DIFFS

diff -Naur xorg/CVS/Entries xorg.new/CVS/Entries
--- xorg/CVS/Entries    2005-12-04 19:27:12.000000000 -0800
+++ xorg.new/CVS/Entries        1969-12-31 16:00:00.000000000 -0800
@@ -1,2 +0,0 @@
-/Portfile/1.5/Sat Feb 12 05:12:51 2005//
-D
diff -Naur xorg/CVS/Repository xorg.new/CVS/Repository
--- xorg/CVS/Repository 2005-12-04 19:27:12.000000000 -0800
+++ xorg.new/CVS/Repository     1969-12-31 16:00:00.000000000 -0800
@@ -1 +0,0 @@
-proj/darwinports/dports/x11/xorg
diff -Naur xorg/CVS/Root xorg.new/CVS/Root
--- xorg/CVS/Root       2005-12-04 19:27:12.000000000 -0800
+++ xorg.new/CVS/Root   1969-12-31 16:00:00.000000000 -0800
@@ -1 +0,0 @@
-:pserver:anonymous@anoncvs.opendarwin.org:/Volumes/src/cvs/od
diff -Naur xorg/CVS/Template xorg.new/CVS/Template
--- xorg/CVS/Template   2005-12-04 19:27:12.000000000 -0800
+++ xorg.new/CVS/Template       1969-12-31 16:00:00.000000000 -0800
@@ -1,11 +0,0 @@
-Bug:            
-Submitted by:   
-Reviewed by:    
-Approved by:    
-Obtained from:  
-CVS: ----------------------------------------------------------------------
-CVS: Bug:             Fill this in if a Bugzilla bug is affected by the change.
-CVS: Submitted by:    Fill this in if someone else sent in the change.
-CVS: Reviewed by:     Fill this in if someone else reviewed your modification.
-CVS: Approved by:     Fill this in if you needed approval for this commit.
-CVS: Obtained from:   Fill this in if the change is from third party software.
diff -Naur xorg/Portfile xorg.new/Portfile
--- xorg/Portfile       2005-12-04 19:27:12.000000000 -0800
+++ xorg.new/Portfile   2005-11-28 13:35:00.000000000 -0800
@@ -4,7 +4,7 @@
 name           xorg
 version                X11R6.8.2
 categories     x11
-maintainers    waqar@opendarwin.org
+maintainers    darwinports@opendarwin.org
 description    The X Window System
 long_description       \
        X11, or X, is a vendor-neutral, system-architecture neutral     \
@@ -28,13 +28,14 @@
                sha1 632e25a202bc41bb9b1c5dbc8bbb0d775c6593b0
 
 worksrcdir     xc
-configure      {
-       set cfpath ${worksrcpath}/config/cf
-       file copy -force ${cfpath}/xorgsite.def ${cfpath}/host.def
+patchfiles     xorg.patch
+configure {
+               set cfpath ${worksrcpath}/config/cf
+               file copy -force ${cfpath}/xorgsite.def ${cfpath}/host.def
 }
 
 build.target   World
-destroot.target install install.man
+destroot.target        install install.man
 
 variant darwin         {
        pre-configure {
@@ -49,6 +50,21 @@
        }
 }
 
+platform darwin 8 {
+       build.env       "CPP=/usr/bin/g++-3.3 \
+                               CC=/usr/bin/gcc-3.3"
+       pre-configure {
+               set hw ${worksrcpath}/programs/Xserver/hw
+               reinplace "s|/Applications|/Applications/DarwinPorts|g" \
+                       ${hw}/darwin/quartz/Imakefile   \
+                       ${hw}/darwin/quartz/XDarwinStartup.man \
+                       ${hw}/xfree86/doc/README.Darwin \
+                       ${hw}/xfree86/doc/sgml/Darwin.sgml \
+                       ${hw}/xfree86/etc/bindist/Darwin-ppc/quartz-list \
+                       ${worksrcpath}/programs/Xserver/Imakefile \
+       }
+}
+
 variant puredarwin {
        post-configure      {
                set hostfd [open "${worksrcpath}/config/cf/host.def" w+]
@@ -59,4 +75,3 @@
                close $hostfd
        }
 }
-
diff -Naur xorg/files/xorg.patch xorg.new/files/xorg.patch
--- xorg/files/xorg.patch       1969-12-31 16:00:00.000000000 -0800
+++ xorg.new/files/xorg.patch   2005-11-27 21:23:23.000000000 -0800
@@ -0,0 +1,137 @@
+--- config/cf/darwin.cf.orig   2004-12-14 23:53:05.000000000 -0500
++++ config/cf/darwin.cf        2005-05-17 15:01:40.000000000 -0400
+@@ -160,7 +160,7 @@
+  * The default cpp-3.3 that ships with Panther inserts spurious #pragmas,
+  * so we use the 3.1-based version.
+  */
+-#if OSMajorVersion >= 7
++#if OSMajorVersion == 7
+ # define CppCmd                 /usr/bin/cpp3
+ # define StandardCppOptions     -traditional -D__GNUC__
+ #else
+--- extras/freetype2/builds/unix/detect.mk.orig        2004-04-28 06:38:58.000000000 -0400
++++ extras/freetype2/builds/unix/detect.mk     2005-05-17 15:01:41.000000000 -0400
+@@ -20,7 +20,8 @@
+   #
+   is_unix := $(strip $(wildcard /sbin/init) \
+                      $(wildcard /usr/sbin/init) \
+-                     $(wildcard /hurd/auth))
++                     $(wildcard /hurd/auth) \
++                     $(wildcard /sbin/launchd))
+   ifneq ($(is_unix),)
+ 
+     PLATFORM := unix
+--- extras/freetype2/include/freetype/freetype.h.orig  2004-04-28 06:38:59.000000000 -0400
++++ extras/freetype2/include/freetype/freetype.h       2005-05-17 15:01:43.000000000 -0400
+@@ -17,11 +17,7 @@
+ 
+ 
+ #ifndef FT_FREETYPE_H
+-#error "`ft2build.h' hasn't been included yet!"
+-#error "Please always use macros to include FreeType header files."
+-#error "Example:"
+-#error "  #include <ft2build.h>"
+-#error "  #include FT_FREETYPE_H"
++#include <ft2build.h>
+ #endif
+ 
+ 
+--- extras/freetype2/src/base/ftapi.c.orig     2003-11-14 11:48:24.000000000 -0500
++++ extras/freetype2/src/base/ftapi.c  2005-05-17 15:01:43.000000000 -0400
+@@ -118,4 +118,18 @@
+   }
+                    
+ 
++  FT_BASE_DEF( FT_Short )
++  FT_Get_Short( FT_Stream stream )
++  {
++    return FT_GET_SHORT();
++  }
++
++
++  FT_BASE_DEF( FT_Long )
++  FT_Get_Long( FT_Stream stream )
++  {
++    return FT_GET_LONG();
++  }
++
++
+ /* END */
+--- extras/freetype2/src/truetype/ttinterp.c.orig      2004-04-28 06:39:07.000000000 -0400
++++ extras/freetype2/src/truetype/ttinterp.c   2005-05-17 15:01:43.000000000 -0400
+@@ -2474,7 +2474,7 @@
+     W = Vx * Vx + Vy * Vy;
+ 
+     /* Now, we want that Sqrt( W ) = 0x4000 */
+-    /* Or 0x1000000 <= W < 0x1004000        */
++    /* Or 0x10000000 <= W < 0x10004000        */
+ 
+     if ( Vx < 0 )
+     {
+@@ -2492,7 +2492,7 @@
+     else
+       S2 = FALSE;
+ 
+-    while ( W < 0x1000000L )
++    while ( W < 0x10000000L )
+     {
+       /* We need to increase W by a minimal amount */
+       if ( Vx < Vy )
+@@ -2503,7 +2503,7 @@
+       W = Vx * Vx + Vy * Vy;
+     }
+ 
+-    while ( W >= 0x1004000L )
++    while ( W >= 0x10004000L )
+     {
+       /* We need to decrease W by a minimal amount */
+       if ( Vx < Vy )
+diff -uNr xc-new/lib/GL/apple/dri_driver.h xc/lib/GL/apple/dri_driver.h
+--- lib/GL/apple/dri_driver.h.orig     2004-04-23 14:43:09.000000000 -0400
++++ lib/GL/apple/dri_driver.h  2005-05-17 15:02:22.000000000 -0400
+@@ -40,6 +40,10 @@
+ #include "Xthreads.h"
+ #include <CoreGraphics/CoreGraphics.h>
+ #include <OpenGL/OpenGL.h>
++#ifndef GL_TYPEDEFS_2_0
++#define GL_TYPEDEFS_2_0
++      typedef char GLchar;
++#endif
+ #include <OpenGL/CGLContext.h>
+ 
+ #ifdef GLX_DIRECT_RENDERING
+--- lib/GL/apple/dri_glx.c.orig        2004-07-27 16:23:58.000000000 -0400
++++ lib/GL/apple/dri_glx.c     2005-05-17 15:01:43.000000000 -0400
+@@ -51,7 +51,7 @@
+ 
+ /* Apple OpenGL "driver" information. */
+ static const char *__driDriverName = "apple";
+-static const char __driConfigOptions[] = "";
++const char __driConfigOptions[] = "";
+ static const int __driDriverMajor = 1;
+ static const int __driDriverMinor = 0;
+ static const int __driDriverPatch = 0;
+--- programs/Xserver/hw/darwin/darwinKeyboard.c.orig   2004-04-23 15:06:15.000000000 -0400
++++ programs/Xserver/hw/darwin/darwinKeyboard.c        2005-05-17 15:01:43.000000000 -0400
+@@ -64,7 +64,9 @@
+ /* Define this to use Alt for Mode_switch. */
+ #define ALT_IS_MODE_SWITCH 1
+ 
+-#include <drivers/event_status_driver.h>
++#define __BEGIN_DECLS
++#define __END_DECLS
++#include <IOKit/hidsystem/event_status_driver.h>
+ #include <IOKit/hidsystem/ev_keymap.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+--- programs/Xserver/hw/darwin/quartz/applewmExt.h.orig        2004-04-23 15:15:17.000000000 -0400
++++ programs/Xserver/hw/darwin/quartz/applewmExt.h     2005-05-17 15:01:43.000000000 -0400
+@@ -59,8 +59,6 @@
+     FrameDrawProc FrameDraw;
+ } AppleWMProcsRec, *AppleWMProcsPtr;
+ 
+-extern AppleWMProcsPtr appleWMProcs;
+-
+ void AppleWMExtensionInit(
+     AppleWMProcsPtr procsPtr
+ );

END DIFFS

Change History (2)

comment:1 Changed 15 years ago by mww@…

Resolution: duplicate
Status: newclosed

* This bug has been marked as a duplicate of 5959 *

comment:2 Changed 5 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: xorg added
Type: defectenhancement
Note: See TracTickets for help on using tickets.