Opened 11 months ago

Closed 10 months ago

Last modified 10 months ago

#59740 closed defect (invalid)

py34-matplotlib depends on nonexistent ports

Reported by: ryandesign (Ryan Schmidt) Owned by: reneeotten (Renee Otten)
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc: mamoll (Mark Moll), dbevans (David B. Evans), stromnov (Andrew Stromnov), michaelld (Michael Dickens)
Port: py-matplotlib, py-gobject3, py-pyqt5, py-pyside, py-seaborn

Description

https://build.macports.org/builders/jobs-mirror/builds/133239/steps/mirror/logs/stdio

--->  Fetching distfiles for py34-matplotlib
Error: No such port: py34-gobject3
Error: No such port: py34-pyqt5
Error: No such port: py34-pyside

Change History (6)

comment:1 Changed 11 months ago by ryandesign (Ryan Schmidt)

Cc: dbevans added

comment:2 Changed 11 months ago by reneeotten (Renee Otten)

Your certainly correct about that. I think part of the problem is that doing port echo depends:py34-<portname> for the ports you listed, actually do not show py34-matplotlib as they're only used in non-default variants. So unless maintainers do some grep-ing on the whole port tree to see if there are dependencies left, this is unfortunately bound to happen.

In this case, since we're anyway trying to get rid of PY34 subports, I would be inclined not to re-add py34 to the ports you listed. Instead, I will continue towards removing py34-matplotlib as well, once I've cleared all its dependents.

comment:3 Changed 11 months ago by ryandesign (Ryan Schmidt)

Removing the py34 subports is fine.

The py38 subports are also affected:

--->  Fetching distfiles for py38-matplotlib
Error: No such port: py38-gobject3
Error: No such port: py38-pyqt4

comment:4 Changed 10 months ago by ryandesign (Ryan Schmidt)

Cc: stromnov michaelld added
Port: py-seaborn added

Can py38-seaborn, py38-gobject3, py38-pyqt4 subports be created, please?

comment:5 Changed 10 months ago by michaelld (Michael Dickens)

I just added those 3. Openmaintainer & simple changes. Verified they build on 10.14 latest everything, but if Py37 worked then Py38 should also work.

comment:6 Changed 10 months ago by michaelld (Michael Dickens)

Resolution: invalid
Status: assignedclosed

py34-matplotlib was removed in [b0a6ad2514502b2d4f0860e9fb4b50d134df6db7/macports-ports], so closing this ticket since it is no longer relevant.

Last edited 10 months ago by ryandesign (Ryan Schmidt) (previous) (diff)
Note: See TracTickets for help on using tickets.