Opened 10 months ago

Closed 9 months ago

#59861 closed defect (fixed)

PDAL: pdal-config output contains -isysroot flag

Reported by: dershow Owned by: Veence (Vincent)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: PDAL

Description (last modified by dershow)

I have the grass7 port installed, version 7.6.1_2. I recently attempted to upgrade, first to version 7.8.1_0, then to 7.8.1_1 and each failed to configure. I've attached the config and main log for the attempt to build 7.8.1_1. Note that qgis3 depends on grass7, so it also will not upgrade.

Attachments (2)

config.log (43.3 KB) - added by dershow 10 months ago.
main.log (2.9 MB) - added by dershow 10 months ago.

Change History (13)

Changed 10 months ago by dershow

Attachment: config.log added

Changed 10 months ago by dershow

Attachment: main.log added

comment:1 Changed 10 months ago by dershow

Description: modified (diff)

comment:2 Changed 10 months ago by jmroot (Joshua Root)

Cc: Veence added

comment:3 Changed 10 months ago by Veence (Vincent)

Yeah, I had the same problem and it took me a while to figure out. I suppose you’re, like me, not running 10.15 yet.

If that assumption is true, then your problem is caused by a misconfiguration in Xcode. Look into that directory /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs

Ideally, you should have this:

drwxr-xr-x  4 root  wheel  128  7 Nov 18:14 DriverKit19.0.sdk
drwxr-xr-x  8 root  wheel  256  7 Nov 18:14 MacOSX.sdk
lrwxr-xr-x  1 root  wheel   10 18 Dec 08:12 MacOSX10.14.sdk -> MacOSX.sdk
lrwxr-xr-x  1 root  wheel   10 11 Dec 08:16 MacOSX10.15.sdk -> MacOSX.sdk

Id the MacOSX10.14.sdk link is missing, create it, and all should be fine henceforth.

comment:4 Changed 10 months ago by dershow

Yes, that worked. Thank you.

comment:5 Changed 10 months ago by Veence (Vincent)

Resolution: wontfix
Status: newclosed

You’re welcome. I close it as "wontfix" since it’s not really tied to the port itself.

comment:6 Changed 10 months ago by jmroot (Joshua Root)

Port: PDAL added; grass7 removed
Resolution: wontfix
Status: closedreopened
Summary: grass7 fails to configurePDAL: pdal-config output contains -isysroot flag

Don't make a fake 10.14 SDK linked to the 10.15 one. That is asking for trouble when features are detected at configure time but then don't exist at runtime. (If everything checked for weak-linked symbols that wouldn't be a problem, but very little in the open source world does.) The real 10.14 SDK should be installed by the Command Line Tools, and base is setting appropriate -isysroot flags to use it.

It looks like the issue is that PDAL has -isysroot hardcoded in its config. That should be removed.

comment:7 Changed 10 months ago by Veence (Vincent)

Fair 'nuff. I never claimed it was anything else than a kludge. How do you install the 10.14 SDK? Command Line Tools doesn't work:

Air > sudo xcode-select --install
xcode-select: error: command line tools are already installed, use "Software Update" to install updates

The 10.14 SDK has just vanished.

comment:8 Changed 10 months ago by ryandesign (Ryan Schmidt)

Cc: Veence removed
Owner: set to Veence
Status: reopenedassigned

comment:9 Changed 9 months ago by Veence (Vincent)

Ryan, you mean that removing the -isysroot flag should solve the issue?

comment:10 Changed 9 months ago by Veence (Vincent)

On both of my computers, the SDK located under /Application/Xcode.app/… is MacOS10.15.sdk, whereas in /Library/Developer/… it is MacOS10.14.sdk.

I think this causes the spurious -isysroot flag inclusion. If I extract PDAL, create a build directory and ccmake from it, there is no -isysroot flag in the pdal-config. This flag only appears when I configure PDAL using macports.

comment:11 Changed 9 months ago by Veence (Vincent)

Resolution: fixed
Status: assignedclosed

I have committed a kludge to fix that. If anyone has a better idea, please be my guest.

Note: See TracTickets for help on using tickets.