#59869 closed defect (duplicate)

re2c @1.3 does not compile on PPC Mac OS C 10.4.11, Tiger, because no match for 'operator!=' in 'c != std::vector<_Tp, _Alloc>::rend() [with _Tp = re2c::clos_t, _Alloc = std::allocator<re2c::clos_t>]()'

Reported by: ballapete (Peter Dyballa) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: tiger Cc:
Port: re2c

Description

/opt/local/bin/g++-apple-4.2 -DHAVE_CONFIG_H -I.   -I/opt/local/include -std=c++98  -W  -Wall  -Wextra  -Weffc++  -pedantic  -Wformat=2  -Wredundant-decls  -Wconversion  -Werror=return-type  -O2  -DRE2C_STDLIB_DIR='"/opt/local/share/re2c/stdlib/"'  -pipe -Os -arch ppc -MT src/dfa/closure.o -MD -MP -MF $depbase.Tpo -c -o src/dfa/closure.o src/dfa/closure.cc &&\
mv -f $depbase.Tpo $depbase.Po
In file included from ./src/dfa/tcmd.h:7,
                 from ./src/dfa/dfa.h:11,
                 from ./src/options/opt.h:10,
                 from ./src/regexp/re.h:5,
                 from ./src/nfa/nfa.h:10,
                 from ./src/dfa/determinization.h:12,
                 from src/dfa/closure.cc:10:
./src/dfa/tag_history.h: In function 'int32_t re2c::compare_reversed(const history_t&, re2c::hidx_t, re2c::hidx_t, size_t)':
./src/dfa/tag_history.h:159: warning: suggest a space before ';' or explicit braces around empty body in 'for' statement
./src/dfa/tag_history.h:160: warning: suggest a space before ';' or explicit braces around empty body in 'for' statement
In file included from ./src/dfa/dfa.h:12,
                 from ./src/options/opt.h:10,
                 from ./src/regexp/re.h:5,
                 from ./src/nfa/nfa.h:10,
                 from ./src/dfa/determinization.h:12,
                 from src/dfa/closure.cc:10:
./src/util/free_list.h: At global scope:
./src/util/free_list.h: In instantiation of 're2c::free_list<re2c::Code*>':
./src/regexp/rule.h:30:   instantiated from here
./src/util/free_list.h:11: warning: base class 'class std::set<re2c::Code*, std::less<re2c::Code*>, std::allocator<re2c::Code*> >' has a non-virtual destructor
src/dfa/closure.cc: In function 'void re2c::generate_stadfa_actions(ctx_t&)':
src/dfa/closure.cc:358: warning: suggest a space before ';' or explicit braces around empty body in 'for' statement
src/dfa/closure.cc:370: warning: suggest a space before ';' or explicit braces around empty body in 'for' statement
src/dfa/closure.cc:395: warning: suggest a space before ';' or explicit braces around empty body in 'for' statement
./src/dfa/closure_posix.h: In function 'void re2c::init_gor1(ctx_t&) [with ctx_t = re2c::determ_context_t<re2c::phistory_t>]':
./src/dfa/closure_posix.h:83:   instantiated from 'void re2c::closure_posix_gor1(ctx_t&) [with ctx_t = re2c::determ_context_t<re2c::phistory_t>]'
./src/dfa/closure_posix.h:38:   instantiated from here
./src/dfa/closure_posix.h:128: error: no match for 'operator!=' in 'c != std::vector<_Tp, _Alloc>::rend() [with _Tp = re2c::clos_t, _Alloc = std::allocator<re2c::clos_t>]()'
make[1]: *** [src/dfa/closure.o] Error 1
make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_devel_re2c/re2c/work/re2c-1.3'
make: *** [all] Error 2
make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_devel_re2c/re2c/work/re2c-1.3'
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_devel_re2c/re2c/work/re2c-1.3" && /usr/bin/make -w all 
Exit code: 2

Attachments (1)

main.log (70.9 KB) - added by ballapete (Peter Dyballa) 16 months ago.
Main.log from PPC Tiger

Download all attachments as: .zip

Change History (3)

Changed 16 months ago by ballapete (Peter Dyballa)

Attachment: main.log added

Main.log from PPC Tiger

comment:1 Changed 16 months ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… removed
Owner: set to ryandesign
Status: newaccepted

comment:2 Changed 16 months ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: acceptedclosed

Duplicate of #58993.

Note: See TracTickets for help on using tickets.