Opened 3 years ago

Closed 3 years ago

#59946 closed defect (fixed)

scribus-devel @1.5.6.svn-20191204 does not configure if python38 is active

Reported by: snowflake (Dave Evans) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.6.99
Keywords: Cc:
Port: scribus-devel

Description

System

"macports_version": "2.6.99",
    "osx_version": "10.11",
     "cxx_stdlib": "libc++",
    "gcc_version": "9.2.0",
    "xcode_version": "8.2.1",
    "clt_version": "8.2.0.0.1.1480973914" 

Configure fails if python38 is active.

From the log:

TIFF Library Found OK
Python 3.x Selected
CMake Error at /opt/local/share/cmake-3.16/Modules/FindPackageHandleStandardArgs.cmake:146 (message):
  Could NOT find Python3 (missing: Development) (found version "3.8.1")
Call Stack (most recent call first):
  /opt/local/share/cmake-3.16/Modules/FindPackageHandleStandardArgs.cmake:393 (_FPHSA_FAILURE_MESSAGE)
  /opt/local/share/cmake-3.16/Modules/FindPython/Support.cmake:2211 (find_package_handle_standard_args)
  /opt/local/share/cmake-3.16/Modules/FindPython3.cmake:300 (include)
  CMakeLists_Dependencies.cmake:140 (find_package)
  CMakeLists.txt:358 (include)
-- Configuring incomplete, errors occurred! 

I deactivated python 38, leaving the following active:

  python33 @3.3.7_3 (active)
  python34 @3.4.10_3 (active)
  python35 @3.5.9_0 (active)
  python36 @3.6.10_0 (active)
  python37 @3.7.6_0+universal (active)
   python39-devel @3.9.0a2_0 (active)

The configure phase now succeeded. There was another build failure after about 15 minutes, but that is probably the subject of another report.

Attachments (1)

Portfile (3.3 KB) - added by snowflake (Dave Evans) 3 years ago.
Portfile for print/scribus-devel

Download all attachments as: .zip

Change History (7)

comment:1 Changed 3 years ago by snowflake (Dave Evans)

cmake in scribus-devel does not appear to like python38 and python39-devel

I deactivated both of them. I also deactivated any port which port rev-upgrade claimed were broken and would rebuild. In my case these were py38-pyqt4 and py38-pyqt5

The configure phase now completed OK.

I then ran port rev-upgrade again.

The build phase got to around 85% when another error occurred.

Here is the error:

:info:build /opt/local/var/macports/build/_Users_davidevans_macports_sources_github.com_macports_macports-ports_print_scribus-devel/scribus-devel/work/scribus-01462934e1d04b9c9b959475f4bcafbca8900297/scribus/plugins/import/pdf/slaoutput.cpp:1197:16: error: no member named 'getEnableFreeType' in 'GlobalParams'
:info:build         globalParams->getEnableFreeType(),
:info:build         ~~~~~~~~~~~~  ^
:info:build 1 error generated.
:info:build make[2]: *** [scribus/plugins/import/pdf/CMakeFiles/importpdf.dir/slaoutput.cpp.o] Error 1
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_Users_davidevans_macports_sources_github.com_macports_macports-ports_print_scribus-devel/scribus-devel/work/build'

comment:2 Changed 3 years ago by snowflake (Dave Evans)

rev-upgrade is complaining because the library provided by poppler is the wrong version for scribus-devel.

Googling for the error message "no member named 'getEnableFreeType' in 'GlobalParams'" finds https://bugs.gentoo.org/704482

Poppler has moved getEnableFreeType

Changed 3 years ago by snowflake (Dave Evans)

Attachment: Portfile added

Portfile for print/scribus-devel

comment:3 Changed 3 years ago by snowflake (Dave Evans)

I've updated the Portfile to the most recent GitHub commit, and the port now builds correctly and rev-upgrade does not complain. I deactivated python38 and python39-devel as per previous comment before stating the build.

The Portfile is attached in the previous comment.

comment:4 Changed 3 years ago by mf2k (Frank Schima)

Thanks. Per the guidelines, please instead attach a unified diff of the Portfile so we can easily see what changes you are proposing. Or better yet, submit a GitHub pull request.

comment:5 Changed 3 years ago by dbevans (David B. Evans)

The current python3 configuration of this port doesn't work well for MacPorts as it assumes by default that the binary python3 is available. Deactivating python38 to build is not a reasonable workaround. I'm looking at a fix for this that avoids having to have manual interversion to configure and will actually select the specified python version.

comment:6 Changed 3 years ago by dbevans (David B. Evans)

Owner: set to dbevans
Resolution: fixed
Status: newclosed

In 799d12043ad5d320f2d18c5d8842bd8ac12e91ea/macports-ports (master):

scribus-devel: update to version 1.5.6.svn git master as of 20200207

  • fix python3 configuration
  • includes build fixes for poppler 0.84.0+.

Supercedes PR https://github.com/macports/macports-ports/pull/6435
Closes #59946

scribus-devel: fix python3 configuration

Note: See TracTickets for help on using tickets.