Opened 7 months ago

Closed 3 weeks ago

Last modified 3 weeks ago

#59965 closed defect (fixed)

netcdf-fortran @4.5.2_0: Parallel build failure

Reported by: Dave-Allured (Dave Allured) Owned by: tenomoto (Takeshi Enomoto)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: netcdf-fortran

Description

A local build from source fails in the middle, on some missing .mod file. The failure is intermittent, but strongly reproducible in my particular macports setup. On each attempt it jumps around to a different missing .mod file name, with port clean used every time in advance. The main command in play is "port -v install".

This port contains a bunch of fortran 90 (*.f90) files. Macports parallel build mode is used by default. An effective work-around is to force serial build mode:

port -v install netcdf-fortran build.jobs=1

I believe this is an upstream problem in the makefile. This is reported upstream and is being worked on: https://github.com/Unidata/netcdf-fortran/issues/208

Main.log from one recent build case is attached.

Attachments (1)

main.0106h.log (130.5 KB) - added by Dave-Allured (Dave Allured) 7 months ago.
Main.log from January 6

Download all attachments as: .zip

Change History (5)

Changed 7 months ago by Dave-Allured (Dave Allured)

Attachment: main.0106h.log added

Main.log from January 6

comment:1 Changed 7 months ago by Dave-Allured (Dave Allured)

Owner: set to tenomoto

comment:2 Changed 3 weeks ago by tenomoto (Takeshi Enomoto)

Resolution: fixed
Status: assignedclosed

I assume that this issue was fixed in 4.5.3.

comment:3 Changed 3 weeks ago by Dave-Allured (Dave Allured)

That update would be PR #7735. I would assume the same thing. I will not have a chance to test this for a while because I do not currently have good access to my test machine. I will update this later when I have a chance.

comment:4 Changed 3 weeks ago by tenomoto (Takeshi Enomoto)

Thank you. I leave this ticket open.

Note: See TracTickets for help on using tickets.