Opened 15 years ago

Closed 15 years ago

#6004 closed defect (fixed)

BUG: apr-util upgrade breaks subversion, reinstallation needed

Reported by: vincent-opdarw@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

The upgrade to apr-util 1.2.2 has the effect to remove /opt/local/lib/libaprutil-0.0.dylib, which is used by subversion:

prunille:~> svn dyld: Library not loaded: /opt/local/lib/libaprutil-0.0.dylib

Referenced from: /opt/local/bin/svn Reason: image not found

Change History (2)

comment:1 Changed 15 years ago by vincent-opdarw@…

Summary: BUG: apr-util upgrade breaks subversionBUG: apr-util upgrade breaks subversion, reinstallation needed

A reinstallation of subversion is needed (after a "port clean" and using the -f option due to dependencies).

comment:2 Changed 15 years ago by danielluke (Daniel J. Luke)

Resolution: fixed
Status: newclosed

I bumped the subversion revision so that this will get automatically built by people who use port upgrade and then file bugs when it doesn't work like how they think it should ;-)

I think there's an existing bug out there to enhance the upgrade procedure to be able to rebuild already installed modules if necessary (this is similar to how one would want to rebuild all of the installed perl modules when installing a new perl version).

Note: See TracTickets for help on using tickets.