Opened 15 months ago

Last modified 7 days ago

#60136 assigned defect

iTerm2 @3.3.9: error: expected ';' after top level declarator

Reported by: JohnFHall (John Hall) Owned by: markemer (Mark Anderson)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: highsierra Cc:
Port: iTerm2

Description (last modified by mf2k (Frank Schima))

Error: Failed to build iTerm2: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_iTerm2/iTerm2/main.log for details.

Attachments (2)

main.log.gz (33.6 KB) - added by JohnFHall (John Hall) 15 months ago.
mail.log.gz
main.log.2.gz (39.7 KB) - added by roberto-marquardt 6 months ago.

Download all attachments as: .zip

Change History (9)

Changed 15 months ago by JohnFHall (John Hall)

Attachment: main.log.gz added

mail.log.gz

comment:1 Changed 14 months ago by mf2k (Frank Schima)

Milestone: MacPorts 2.7.0

The Milestone field is for use by Macports team members only, please do not set it.

comment:2 Changed 14 months ago by mf2k (Frank Schima)

Cc: mark@… GitHub: markemer removed

Only enter valid email addresses or GitHub handles into the Cc field.

comment:3 Changed 14 months ago by mf2k (Frank Schima)

Owner: set to markemer
Status: newassigned

comment:4 Changed 14 months ago by mf2k (Frank Schima)

Description: modified (diff)

In the future, please use WikiFormatting.

comment:5 Changed 14 months ago by markemer (Mark Anderson)

I'll take a look at this - building on lower than 10.15 is becoming a challenge.

Changed 6 months ago by roberto-marquardt

Attachment: main.log.2.gz added

comment:6 Changed 6 months ago by roberto-marquardt

iTerm2 fails to build 3.3.12, 3.3.11, 3.3.10, 3.3.9 updates (see attached log file for 3.3.12)

iTerm2 build succeeds for 3.3.7 update from github repository

comment:7 Changed 7 days ago by ryandesign (Ryan Schmidt)

Keywords: highsierra added
Summary: iTerm2 fails to build 3.3.9 updateiTerm2 @3.3.9: error: expected ';' after top level declarator

Both attached logs are from macOS 10.13 and show this error:

.../sources/DVRDecoder.m:243:34: error: expected ';' after top level declarator

One log is from 3.3.9, one is from 3.3.12.

Note: See TracTickets for help on using tickets.