Opened 15 years ago

Closed 14 years ago

#6017 closed defect (worksforme)

BUG: can't upgrade curl (tries to activate the current version!)

Reported by: vincent-opdarw@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.0
Keywords: Cc: markd@…
Port:

Description

prunille:~> port installed curl

curl 7.14.0_0+ipv6 curl 7.14.1_0+ipv6 curl 7.15.0_0+darwin_8 curl 7.15.0_0+darwin_8+ipv6 (active)

"port outdated" gives in particular:

curl 7.15.0_0 < 7.15.1_0

but "sudo port -d upgrade curl" gives the following error:

DEBUG: Found port in file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/net/curl ---> Activating curl 7.15.0_0+darwin_8+ipv6 DEBUG: Image error: curl 7.15.0_0+darwin_8+ipv6 is already active.

while executing

"portimage::activate $portname $version_installed$variant" Error: Activating curl 7.15.0_0 failed: Image error: curl 7.15.0_0+darwin_8+ipv6 is already active.

Change History (16)

comment:1 Changed 15 years ago by yeled@…

Component: dportsbase

This is more likely a base/ problem.

comment:2 Changed 15 years ago by yeled@…

Owner: changed from yeled@… to darwinports-bugs@…

Vincent,

is this with 1.02?

comment:3 Changed 15 years ago by yeled@…

Cc: yeled@… added

comment:4 Changed 15 years ago by vincent-opdarw@…

This is with 1.102.

comment:5 Changed 15 years ago by yeled@…

(In reply to comment #3)

This is with 1.102.

bugger. works for me with 1.200

comment:6 Changed 15 years ago by vincent-opdarw@…

I've just upgrade to 1.200 and I have the same problem.

comment:7 Changed 15 years ago by yeled@…

Cc: yeled@… removed
Owner: changed from darwinports-bugs@… to yeled@…

comment:8 Changed 15 years ago by yeled@…

Status: newassigned

I see this.

19:26 backspace:dports/net/curl% sudo port -d upgrade curl DEBUG: Found port in file:///Users/yeled/Documents/darwinports/dports/net/curl ---> Activating curl 7.15.1_0+darwin_8+idn DEBUG: Image error: Another version of curl (7.15.0_0+darwin_8+ipv6) is already active.

while executing

"portimage::activate $portname $version_installed$variant $optionslist" Error: Activating curl 7.15.1_0 failed: Image error: Another version of curl (7.15.0_0+darwin_8+ipv6) is already active. 19:26 backspace:dports/net/curl%

comment:9 Changed 15 years ago by vincent-opdarw@…

After uninstalling the 3 old curl versions, I could upgrade curl.

comment:10 Changed 15 years ago by yeled@…

Owner: changed from yeled@… to darwinports-bugs@…
Status: assignednew

it has something to do with renaming variables and therefore not running portimage::deactivate

set version_installed $version - perhaps?

darwinports.tcl: line 1526 or so....

If anyone else wants to have a crack at this..

comment:11 Changed 15 years ago by jmpp@…

Vincent, if you still have the four old curl packages somewhere around I would like you to do something for me, please, to rule out (or not) the upgrade procedure as the culprit:

-) uninstall (and clean) the newest curl; -) install the four old ones and keep active the newest of those (curl 7.15.0_0+darwin_8+ipv6); -) run por outdated to confirm the newest curl in the repo; -) deactivate curl 7.15.0_0+darwin_8+ipv6 manually; -) install the newest one manually with the same varianst as the recently deactivated one (you'll have to add them manually too).

This should be the same test case as the one you orginally dealt with, with the small difference that we're short circuiting the upgrade prodecure and doing it manually. If this succeeds, then we know where the bug is (upgrade); if not, then we can look elsewhere (like Charlie's suggestion).

I'd appreciate it if you could help us with this, Vincent. Regards,

-jmpp

comment:12 Changed 15 years ago by vincent-opdarw@…

I have the following archives:

/opt/local/var/db/dports/packages/darwin/powerpc/curl-7.14.0_0+ipv6.powerpc.tgz /opt/local/var/db/dports/packages/darwin/powerpc/curl-7.14.0_0.powerpc.tgz /opt/local/var/db/dports/packages/darwin/powerpc/curl-7.14.1_0+ipv6.powerpc.tgz /opt/local/var/db/dports/packages/darwin/powerpc/curl-7.15.0_0+darwin_8+ipv6.powerpc.tgz /opt/local/var/db/dports/packages/darwin/powerpc/curl-7.15.0_0+darwin_8.powerpc.tgz

but I don't know to install them.

"sudo port -b -v install curl @7.14.0_0+ipv6" tries to fetch curl 7.15.1.

comment:13 Changed 15 years ago by jmpp@…

(In reply to comment #10)

I have the following archives:

/opt/local/var/db/dports/packages/darwin/powerpc/curl-7.14.0_0+ipv6.powerpc.tgz /opt/local/var/db/dports/packages/darwin/powerpc/curl-7.14.0_0.powerpc.tgz /opt/local/var/db/dports/packages/darwin/powerpc/curl-7.14.1_0+ipv6.powerpc.tgz /opt/local/var/db/dports/packages/darwin/powerpc/curl-7.15.0_0+darwin_8+ipv6.powerpc.tgz /opt/local/var/db/dports/packages/darwin/powerpc/curl-7.15.0_0+darwin_8.powerpc.tgz

but I don't know to install them.

"sudo port -b -v install curl @7.14.0_0+ipv6" tries to fetch curl 7.15.1.

Hi Vincent! I don't seem to remember either how to install from already existing archives if the version/ revision in the Portfile/PortIndex is newer, so my recommendation is this:

-) cd $(port dir curl | tr "\r" "\n") (the "tr" part is because for some reason tcl's "puts" echos \r as a newline character on my system, instead of \n; you might not need that); -) edit the Portfile therein to reflect the version/revision you want to install; -) issue "port install +variant1 +variant2 +etc...", explicitly omitting the portname, in order to force dp to look at the current pwd for a Portfile rather than searching the index.

Following that recipe you should be able to install from any of the binary archives you already have and continue with the testings I requested. Thanks!

-jmpp

comment:14 Changed 14 years ago by markd@…

Cc: markd@… added

Is this still reproducible?

comment:15 Changed 14 years ago by vincent-opdarw@…

I think I had no such problems in the latest upgrades, and I didn't have the time to reproduce it with old binaries (and my Power Mac is still being repaired).

comment:16 Changed 14 years ago by markd@…

Resolution: worksforme
Status: newclosed

(In reply to comment #13)

I think I had no such problems in the latest upgrades, and I didn't have the time to reproduce it with old binaries (and my Power Mac is still being repaired).

Okay thanks. I'll close it. It can be reopened if necessary.

Note: See TracTickets for help on using tickets.