Opened 7 months ago

Closed 7 months ago

#60327 closed defect (invalid)

python38 +universal fails to install under MacOS 10.15.4 or Catalina update 4 with MacPorts 2.6.2

Reported by: oldbonez Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: python38

Description (last modified by oldbonez)

python38 +universal fails to install under MacOS 10.15.4 or Catalina update 4

How to reproduce:

# sudo port self-update
# sudo port upgrade outdated
--->  Computing dependencies for python38
--->  Fetching archive for python38
--->  Attempting to fetch python38-3.8.2_0+universal.darwin_19.x86_64.tbz2 from https://packages.macports.org/python38
--->  Attempting to fetch python38-3.8.2_0+universal.darwin_19.x86_64.tbz2 from http://nue.de.packages.macports.org/python38
--->  Attempting to fetch python38-3.8.2_0+universal.darwin_19.x86_64.tbz2 from http://lil.fr.packages.macports.org/python38
--->  Fetching distfiles for python38
--->  Verifying checksums for python38
--->  Extracting python38
--->  Applying patches to python38
--->  Configuring python38
--->  Building python38
--->  Staging python38 into destroot
Error: Failed to destroot python38: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_python38/python38/main.log for details.
Error: Problem while installing python38
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

Attachments (2)

python38-main.log (382.1 KB) - added by oldbonez 7 months ago.
main.log from the compilation
main.log (381.9 KB) - added by oldbonez 7 months ago.
main.log from the compilation with Xcode 11.4

Download all attachments as: .zip

Change History (13)

Changed 7 months ago by oldbonez

Attachment: python38-main.log added

main.log from the compilation

comment:1 Changed 7 months ago by oldbonez

Description: modified (diff)

comment:2 Changed 7 months ago by oldbonez

Description: modified (diff)

comment:3 Changed 7 months ago by oldbonez

Description: modified (diff)

comment:4 Changed 7 months ago by oldbonez

Description: modified (diff)

comment:5 Changed 7 months ago by oldbonez

Description: modified (diff)

comment:6 Changed 7 months ago by mf2k (Frank Schima)

Keywords: python38 removed

Changed 7 months ago by oldbonez

Attachment: main.log added

main.log from the compilation with Xcode 11.4

comment:7 Changed 7 months ago by reneeotten (Renee Otten)

it appears that you're trying to build +universal - why? I don't think Mojave or Catalina will do universal builds since they only support x86_64. At least when I do sudo port install python38 +universal on Mojave, I get the following message:

Error: python38 cannot be installed for the configured universal_archs 'x86_64 i386' because the arch(s) 'i386' are not supported.

Did you by any chance upgrade your OS and didn't (completely) follow the migration procedure?

comment:8 Changed 7 months ago by oldbonez

Hi Renee,

I have +universal set from older macports installations and universal_archs x86_64 set in /opt/local/etc/macports/macports.conf. I didn't follow the entire Macports upgrade procedure on https://trac.macports.org/wiki/Migration. Just reinstalled ports and that was it. Shall I follow the procedure and try later?

Last edited 7 months ago by oldbonez (previous) (diff)

comment:9 Changed 7 months ago by oldbonez

switching to +optimizations variant of python38 and setting build_arch to x86_64 in macports.conf did the trick Ticket can be closed.

comment:10 Changed 7 months ago by oldbonez

Description: modified (diff)
Summary: python38 fails to install under MacOS 10.15.4 or Catalina update 4 with MacPorts 2.6.2python38 +universal fails to install under MacOS 10.15.4 or Catalina update 4 with MacPorts 2.6.2

comment:11 in reply to:  9 Changed 7 months ago by reneeotten (Renee Otten)

Resolution: invalid
Status: newclosed

Replying to oldbonez:

switching to +optimizations variant of python38 and setting build_arch to x86_64 in macports.conf did the trick

I am pretty sure that only changing macports.conf would be sufficient and you don't need the variant. But in either case, I am happy it worked now - you see there is a reason why there is MigrationProcedure ;)

Note: See TracTickets for help on using tickets.