Opened 8 weeks ago

Last modified 5 weeks ago

#60338 assigned defect

py-spyder @4.1.2: immediate crash after launch on macOS 10.13.6 High Sierra

Reported by: mgeever (Michael Geever) Owned by: reneeotten (Renee Otten)
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc:
Port: py-spyder

Description (last modified by mf2k (Frank Schima))

py-spyder and all required dependencies installed with no errors. The application starts up, gets to the main screen and then immediately crashes with the following error:

[1285:79363:0409/203241.695764:FATAL:gpu_data_manager_impl_private.cc(919)] The display compositor is frequently crashing. Goodbye.
Trace/BPT trap: 5

From what I've read, it looks like it might be related to chromium but I'm really quite out of my depth after that. Be most grateful for any help or guidance.

Attachments (2)

spyder-debug.log (98.9 KB) - added by mgeever (Michael Geever) 5 weeks ago.
Spyder debug log
py37-spyder_macport_backtrace.txt (144.7 KB) - added by mgeever (Michael Geever) 5 weeks ago.
py37-spyder backtrace

Download all attachments as: .zip

Change History (5)

comment:1 Changed 8 weeks ago by mf2k (Frank Schima)

Cc: reneeotten removed
Description: modified (diff)
Keywords: highsierra spyder removed
Owner: set to reneeotten
Status: newassigned

comment:2 Changed 7 weeks ago by reneeotten (Renee Otten)

hi Michael, sorry for the trouble and unfortunately I'm not sure if I can be of much help... I haven't seen this issue myself and there seem to be no reports of it upstream.

First off, what do you means with py-spyder - for which Python version did you install the port (i.e., what is XY in sudo port install pyXY-spyder? Secondly, did you upgrade from an earlier v4.x version when this issue started or from v3.x?

Assuming that you haven't customized the Spyder settings too much, I would recommend resetting those to their defaults using spyder-XY --reset. Additionally, you could start the program with more debugging output using pyXY-spyder --debug-info verbose --debug-output file; this will result in a file spyder-debug.log in the directory where you started the program. Please add that file as an attachment to this ticket.

Finally, if it has something to do with the displaying stuff you might want to try another option for --opengl and see if that makes a difference (the default appears to be "software").

  --opengl {software,desktop,gles}
                        OpenGL implementation to pass to Qt

Additionally, it would be useful to find out whether this is an upstream issue or due to the packaging in MacPorts (i.e., can you try to install Spyder through Anaconda and see if you can reproduce the issue?).

Changed 5 weeks ago by mgeever (Michael Geever)

Attachment: spyder-debug.log added

Spyder debug log

Changed 5 weeks ago by mgeever (Michael Geever)

py37-spyder backtrace

comment:3 Changed 5 weeks ago by mgeever (Michael Geever)

Hi and thank you for a detailed reply.

First of all, you last suggestion of change the OpenGL option appears to have worked. I started spyder with: spyder --opengl desktop and it worked and appears to be stable and working fine.

But, in case it's useful to figure out the problem with the default OpenGL settings, I've attached the Spyder-debug.log and the backtrace. Hope that can help shed light on it somehow.

The port I installed is: py37-spyder. It's a fresh first-time install, not an update. The Spyder version is 4.1.2. I hadn't changed any of the settings because I didn't even get that far as the app crashed almost immediately on startup. I did the reset with: spyder --reset. It did reset various things in the .spyder4-37 directory in my home directory but the app still crashed on launch.

I previously had a working Anaconda install but, after adding some python library, it looks like spyder also got updated and didn't work after that. I tried to remove and reinstall Anaconda a few times but spyder never worked after that. I think I read somewhere that Anaconda my have dropped support for the processor in this machine. It's a bit old I suppose: mid 2010 MacBook Pro with 2.66 GHz i7.

Thank you so much for figuring out the problem - I really appreciated you time and expertise. I hope this information will be useful somehow to help to debug the issue with the default OpenGL settings (if indeed it is a bug).

Thank you!

Michael.

Note: See TracTickets for help on using tickets.