Opened 15 months ago

Last modified 14 months ago

#60345 reopened defect

R-app: error: Compiling for earlier than macOS 10.6 is no longer supported

Reported by: LenoreHorner Owned by: kjellpk (Kjell Konis)
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc:
Port: R-app

Description

Even after clean and re-attempt, R-app fails. R installed successfully. MacOS 10.14.6

Attachments (1)

R-app_main.log (247.5 KB) - added by LenoreHorner 15 months ago.
main.log

Download all attachments as: .zip

Change History (6)

Changed 15 months ago by LenoreHorner

Attachment: R-app_main.log added

main.log

comment:1 Changed 15 months ago by jmroot (Joshua Root)

Owner: set to kjellpk

comment:2 Changed 14 months ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed
Summary: R-app failsR-app: error: Compiling for earlier than macOS 10.6 is no longer supported

The log says:

error: Compiling for earlier than macOS 10.6 is no longer supported

So this is a duplicate of

comment:3 Changed 14 months ago by LenoreHorner

Resolution: duplicate
Status: closedreopened

That is not, however, the only error, nor even the first error. Hence the new ticket. See log file.

comment:4 Changed 14 months ago by LenoreHorner

Sorry, Ryan, didn't see your detailed response about what the errors mean until after I'd responded here (different mailboxes).

comment:5 Changed 14 months ago by kencu (Ken)

FYI, you see that ibtool error quite often since xcode 10; I usually just reinplace 10.5 to 10.6 in the xib files affected.

Note: See TracTickets for help on using tickets.