Opened 6 months ago

Closed 6 months ago

#60358 closed defect (fixed)

kops should depend on kubectl-1.17 now instead of obsolete kubectl package

Reported by: gworley3 (G Gordon Worley III) Owned by: mf2k (Frank Schima)
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc:
Port: kops

Description

$ sudo port install kops
--->  Computing dependencies for kops
The following dependencies will be installed:  kubectl
Continue? [Y/n]:
--->  Configuring kubectl
Error: kubectl has been replaced by kubectl-1.17; please install that instead.
Error: Failed to configure kubectl: obsolete port
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_sysutils_kubectl/kubectl/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port kops failed

Change History (1)

comment:1 Changed 6 months ago by mf2k (Frank Schima)

Owner: set to mf2k
Resolution: fixed
Status: newclosed

In 5e7364c0fc7283b8891ce091d3e2795a4110e5fe/macports-ports (master):

kops: Fix dependencies

Fixes: #60358

Note: See TracTickets for help on using tickets.