Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#60373 closed defect (duplicate)

error when trying to install wine "wine cannot be installed for the configured build_arch 'x86_64' because it only supports the arch(s) 'i386'"

Reported by: schim77 Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: wine

Description (last modified by ryandesign (Ryan Schmidt))

I tried to install wine because I want to run Windows applications on my Mac (could not find a Mac alternative for this application).
I ran this command: $ sudo port install wine I got this error:

Error: wine cannot be installed for the configured build_arch 'x86_64' because it only supports the arch(s) 'i386'
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port wine failed

I tried to clean it first and then tried installing again, but that didn't work.

Cheers, Romee

Change History (6)

comment:1 Changed 6 months ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: wine x86_64 i386 removed

Which operating system version? At this time, the wine ports cannot be installed on macOS 10.14 Mojave or later.

comment:2 Changed 6 months ago by schim77

Well then is this the answer. I have 10.15.4 MacOS Catalina. Thanks for your answer @ryandesign.

Is there another way to install wine on my Mac with MacOS Catalina? Because I want to run an application like AeroAdmin to help my parents with their computer (long distance).

comment:3 Changed 6 months ago by kencu (Ken)

There is a 64bit version of wine coming along eventually. If you scour the winehq forums you'll likely come across a way to run the 64bit wine on Catalina now. This looks promising <https://forum.winehq.org/viewtopic.php?t=33154>, as does this <https://forum.winehq.org/viewforum.php?f=9> do it looks like some people have figured it out.

If that didn't work out and I wanted to do this spending no money, I'd try installing High Sierra in VirtualBox and then installing Wine on there. That would let you run 32bit apps on your system, although it would burn up some disk space for the High Sierra overhead.

Or just buy Parallels and install Windows10 in it, or BootCamp with Windows10. That's the most reliable (but most expensive) way...but comes a time when "time is money" and that approach "just works" for almost everything, including all those Steam games that are Win only.

comment:4 Changed 6 months ago by jmroot (Joshua Root)

CrossOver does work on Catalina now BTW.

comment:5 Changed 6 months ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #56991.

comment:6 Changed 6 months ago by ryandesign (Ryan Schmidt)

Cc: ryandesign added
Note: See TracTickets for help on using tickets.