Opened 3 weeks ago

Last modified 6 days ago

#60447 assigned defect

/opt/local/bin/emacs won't run on Catalina

Reported by: dhmacq Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: texas-swift, majoc-at-astro (majoc-at-astro)
Port: emacs

Description

[7]% which emacs /opt/local/bin/emacs [8]% emacs Killed

This is after upgrading the machine to Catalina, updating Xcode, reinstalling XQuartz, fresh install of MacPorts for Catalina, then

sudo port install emacs +x11

No errors reported by port install.

Also tried it with MacPorts xorg-server

Change History (8)

comment:1 Changed 3 weeks ago by jmroot (Joshua Root)

Owner: set to drkp
Port: emacs added
Status: newassigned

comment:2 Changed 8 days ago by texas-swift

Cc: texas-swift added

comment:3 Changed 8 days ago by majoc-at-astro (majoc-at-astro)

Cc: majoc-at-astro added

comment:4 Changed 8 days ago by majoc-at-astro (majoc-at-astro)

For completeness, I find this failure on 10.15 after our standard twice-weekly build from scratch, both on my mactop and on the build system, but not on the 10.14 builder (10.13 not tried yet). There may or may not be a connection with a recent 10.15 macOS update, but that may be a herring of the reddest order.

Info for the 10.15 build system in question:

MacPorts Version: 2.6.2

macOS 10.15.4

  • Build: 19E287

Xcode 11.3

  • Xcode: Build version 11C29
  • clang: Apple clang version 11.0.0 (clang-1100.0.33.16)

Hope this helps.

comment:5 Changed 8 days ago by majoc-at-astro (majoc-at-astro)

PS: my symptoms are:

% port installed |grep emacs
  emacs @26.3_2+x11 (active)
% which emacs
/opt/local/bin/emacs
% emacs --version
zsh: killed     emacs --version
%

.... very abruptly.

comment:6 Changed 7 days ago by majoc-at-astro (majoc-at-astro)

This just in:

  • port install emacs installs precompiled binaries of emacs @26.3_2, which work fine.
  • port -s install emacs builds emacs @26.3_2 from source without +x11; the result dies on launch.
  • Installing emacs-devel @20200417_0+x11 builds from source and installs OK on my 10.15 mactop; result successfully runs, and bills itself as GNU Emacs 27.0.91.
  • Latter build took rather longer, and spends much of that time running emacs-bootstrap. (Curious, but I'll resist the urge to speculate further, lest I spoil the kill.)

I'll use emacs-devel +x11 in active service for a few days to check for anomalies, and see what our build servers make of it (on macOS 10.13--10.15); but I think we have a workaround, Houston.

comment:7 Changed 6 days ago by dhmacq

I can confirm that

sudo port install emacs-devel +x11

provides a working X11 enabled emacs on my

macOS 10.15.4 (19E287)

sytem. Subsequent to the install:

macq[4]% emacs --version
GNU Emacs 27.0.91
Copyright (C) 2020 Free Software Foundation, Inc.
GNU Emacs comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GNU Emacs
under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING.
macq[5]% which emacs
/opt/local/bin/emacs

Great news, thanks! Much appreciated.

comment:8 in reply to:  7 Changed 6 days ago by majoc-at-astro (majoc-at-astro)

Replying to dhmacq:

Great news, thanks! Much appreciated.

Glad to be of service.

Note: See TracTickets for help on using tickets.