Opened 7 weeks ago

Closed 7 weeks ago

#60483 closed defect (duplicate)

py-spaCy @2.2.4: distutils.errors.DistutilsError: the `allow-hosts` option is not supported when using pip to install requirements

Reported by: museum-future (Skynet) Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc: cjones051073 (Chris Jones)
Port: py-spaCy

Description

Hello,

I can't get this install with python 3.7 or 3.8

From my logfile from python 3.7

:info:build Traceback (most recent call last):
:info:build   File "setup.py", line 200, in <module>
:info:build     setup_package()
:info:build   File "setup.py", line 195, in setup_package
:info:build     cmdclass={"build_ext": build_ext_subclass},
...
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/setuptools/installer.py", line 83, in fetch_build_egg
:info:build     raise DistutilsError('the `allow-hosts` option is not supported '
:info:build distutils.errors.DistutilsError: the `allow-hosts` option is not supported when using pip to install requirements.
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_python_py-spaCy/py37-spaCy/work/spaCy-2.2.4" && /opt/local/Library/Frameworks/Python.framework/Versions/3.7/bin/python3.7 setup.py build_ext --inplace build -j32 
:info:build Exit code: 1
:error:build Failed to build py37-spaCy: command execution failed

It seems like known issue for spaCy, this is a bug for version 2.1.0

"https://github.com/explosion/spaCy/issues/5426"

Change History (2)

comment:1 Changed 7 weeks ago by museum-future (Skynet)

Keywords: python inconsistencies added

added keywords

comment:2 Changed 7 weeks ago by ryandesign (Ryan Schmidt)

Cc: cjones051073 added; @… removed
Keywords: python inconsistencies removed
Resolution: duplicate
Status: newclosed
Summary: py-spaCypy-spaCy @2.2.4: distutils.errors.DistutilsError: the `allow-hosts` option is not supported when using pip to install requirements

Duplicate of #60474.

Note: See TracTickets for help on using tickets.