Opened 8 weeks ago

Closed 8 weeks ago

#60495 closed defect (duplicate)

libsoup needs a library dependency on libpsl

Reported by: himatech Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc:
Port: libsoup

Description

Hi, I'm trying to install gnome on my Catalina but I'm having a problem with geoclue2. Here is the output:

--->  Fetching archive for geoclue2
--->  Attempting to fetch geoclue2-2.4.12_1+x11.darwin_19.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/geoclue2
--->  Attempting to fetch geoclue2-2.4.12_1+x11.darwin_19.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/geoclue2
--->  Attempting to fetch geoclue2-2.4.12_1+x11.darwin_19.x86_64.tbz2 from http://lil.fr.packages.macports.org/geoclue2
--->  Configuring geoclue2
Error: Failed to configure geoclue2, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_geoclue2/geoclue2/work/geoclue-2.4.12/config.log
Error: Failed to configure geoclue2: configure failure: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_geoclue2/geoclue2/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port gnome failed

I'm running Catalina 10.15.4 and macports 2.6.2.

Attachments (2)

config.log (44.6 KB) - added by himatech 8 weeks ago.
config.log
main.log (306.3 KB) - added by himatech 8 weeks ago.
main.log

Download all attachments as: .zip

Change History (4)

Changed 8 weeks ago by himatech

Attachment: config.log added

config.log

Changed 8 weeks ago by himatech

Attachment: main.log added

main.log

comment:1 Changed 8 weeks ago by ryandesign (Ryan Schmidt)

Keywords: geoclue2 removed
Owner: set to dbevans
Port: libsoup added; gnome removed
Status: newassigned
Summary: gnome: Install Error: Failed to configure geoclue2libsoup needs a library dependency on libpsl
Version: 2.6.2

The main.log says:

:info:configure checking for
:info:configure   glib-2.0 >= 2.44.0
:info:configure   gio-2.0 >= 2.44.0
:info:configure   gio-unix-2.0 >= 2.44.0
:info:configure   json-glib-1.0 >= 0.14
:info:configure   libsoup-2.4 >= 2.42
:info:configure ... no
:info:configure configure: error: Package requirements (
:info:configure   glib-2.0 >= 2.44.0
:info:configure   gio-2.0 >= 2.44.0
:info:configure   gio-unix-2.0 >= 2.44.0
:info:configure   json-glib-1.0 >= 0.14
:info:configure   libsoup-2.4 >= 2.42
:info:configure ) were not met:
:info:configure Package 'libpsl', required by 'libsoup-2.4', not found

config.log says:

configure:13563: $PKG_CONFIG --exists --print-errors "
  glib-2.0 >= $GLIB_MIN_VERSION
  gio-2.0 >= $GLIB_MIN_VERSION
  gio-unix-2.0 >= $GLIB_MIN_VERSION
  json-glib-1.0 >= $JSON_GLIB_MIN_VERSION
  libsoup-2.4 >= $LIBSOUP_MIN_VERSION
"
Package libpsl was not found in the pkg-config search path.

I guess the libsoup port needs a library dependency on the libpsl port.

comment:2 Changed 8 weeks ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Duplicate of #60489.

Note: See TracTickets for help on using tickets.