Opened 8 weeks ago

Closed 8 weeks ago

#60501 closed defect (invalid)

youtube-dl: Unable to download webpage

Reported by: jpmelko Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: melanieledu@…
Port: youtube-dl

Description

occurs with all videos

 youtube-dl 'https://www.youtube.com/watch?v=HF9GwOptEDU'
[youtube] HF9GwOptEDU: Downloading webpage
ERROR: Unable to download webpage: <urlopen error [Errno 64] Host is down> (caused by URLError(OSError(64, 'Host is down')))

worked yesterday

changes from yesterday in macports

freetype @2.10.1_0 | freetype @2.10.2_0 
python38 @3.8.2_0  | python38 @3.8.3_0 

youtube-dl --version 2020.05.08

Change History (8)

comment:1 Changed 8 weeks ago by jpmelko

In Terminal:

 cd /Users/titi/Downloads ; /opt/local/bin/youtube-dl --ignore-config --no-playlist --quiet  --socket-timeout 180  --output '%(title)s-%(id)s-22-1280x720.%(ext)s' --format 22 'https://www.youtube.com/watch?v=HF9GwOptEDU'
ERROR: Unable to download webpage: <urlopen error [Errno 64] Host is down> (caused by URLError(OSError(64, 'Host is down')))
titi@Bacchus Downloads % 

Dont Works

It is not a PATH problem, I have tried

In Script Editor

set thecommand to " cd /Users/titi/Downloads ; /opt/local/bin/youtube-dl --ignore-config --no-playlist --quiet  --socket-timeout 180  --output '%(title)s-%(id)s-22-1280x720.%(ext)s' --format 22 'https://www.youtube.com/watch?v=HF9GwOptEDU'"
log thecommand
do shell script thecommand

Works

Any idea ????

comment:2 Changed 8 weeks ago by jpmelko

forgot --verbose

titi@Bacchus Downloads % cd /Users/titi/Downloads ; /opt/local/bin/youtube-dl --ignore-config --no-playlist --quiet  --socket-timeout 180  --output '%(title)s-%(id)s-22-1280x720.%(ext)s' --format 22 'https://www.youtube.com/watch?v=HF9GwOptEDU' --verbose
[debug] System config: []
[debug] User config: []
[debug] Custom config: []
[debug] Command-line args: ['--ignore-config', '--no-playlist', '--quiet', '--socket-timeout', '180', '--output', '%(title)s-%(id)s-22-1280x720.%(ext)s', '--format', '22', 'https://www.youtube.com/watch?v=HF9GwOptEDU', '--verbose']
[debug] Encodings: locale UTF-8, fs utf-8, out utf-8, pref UTF-8
[debug] youtube-dl version 2020.05.08
[debug] Python version 3.8.3 (CPython) - macOS-10.15.4-x86_64-i386-64bit
[debug] exe versions: ffmpeg 4.2.2, ffprobe 4.2.2, rtmpdump 2.4
[debug] Proxy map: {}
ERROR: Unable to download webpage: <urlopen error [Errno 64] Host is down> (caused by URLError(OSError(64, 'Host is down')))
  File "/opt/local/bin/youtube-dl/youtube_dl/extractor/common.py", line 627, in _request_webpage
    return self._downloader.urlopen(url_or_request)
  File "/opt/local/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 2238, in urlopen
    return self._opener.open(req, timeout=self._socket_timeout)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/urllib/request.py", line 525, in open
    response = self._open(req, data)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/urllib/request.py", line 542, in _open
    result = self._call_chain(self.handle_open, protocol, protocol +
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/urllib/request.py", line 502, in _call_chain
    result = func(*args)
  File "/opt/local/bin/youtube-dl/youtube_dl/utils.py", line 2728, in https_open
    return self.do_open(functools.partial(
  File "/opt/local/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/urllib/request.py", line 1353, in do_open
    raise URLError(err)

comment:3 in reply to:  description Changed 8 weeks ago by ryandesign (Ryan Schmidt)

Summary: Unable to download webpage:youtube-dl: Unable to download webpage

Replying to jpmelko:

occurs with all videos

 youtube-dl 'https://www.youtube.com/watch?v=HF9GwOptEDU'
[youtube] HF9GwOptEDU: Downloading webpage
ERROR: Unable to download webpage: <urlopen error [Errno 64] Host is down> (caused by URLError(OSError(64, 'Host is down')))

It works fine for me. Maybe there is a problem with your network, incorrect proxy settings, or maybe you have installed antivirus software that is interfering with your network.

comment:4 Changed 8 weeks ago by jpmelko

port uninstall youtube-dl
port install youtube-dl +ffmpeg+python37

and now it works remember that python38 has changed recently

when I reinstall with python38 it does not works

This does not explains why it worked in AppleScript with python38

comment:5 Changed 8 weeks ago by jpmelko

titi@Bacchus Downloads % printenv
TMPDIR=/var/folders/0b/dh9y8mt90yz8lw02t9yzdr780000gp/T/
XPC_FLAGS=0x0
TERM_PROGRAM_VERSION=433
LANG=fr_FR.UTF-8
TERM_PROGRAM=Apple_Terminal
XPC_SERVICE_NAME=0
TERM_SESSION_ID=64A5682F-36C7-499E-8946-5E4D79362C2C
TERM=xterm-256color
SSH_AUTH_SOCK=/private/tmp/com.apple.launchd.OPEjvnHWCR/Listeners
SHELL=/bin/zsh
HOME=/Users/titi
LOGNAME=titi
USER=titi
PATH=/opt/local/bin:/opt/local/sbin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/Apple/usr/bin
SHLVL=1
PWD=/Users/titi/Downloads
OLDPWD=/Users/titi
HISTFILESIZE=8192
HISTSIZE=2000
ZIPOPT=--symlinks
_=/usr/bin/printenv

comment:6 Changed 8 weeks ago by ryandesign (Ryan Schmidt)

Owner: set to ryandesign
Status: newassigned

It works fine for me with +python38. I don't have any other suggestions for why it doesn't work for you.

comment:7 Changed 8 weeks ago by jpmelko

Close this ticket please. It was a littlesnitch rule

Sorry

comment:8 Changed 8 weeks ago by kencu (Ken)

Resolution: invalid
Status: assignedclosed

thanks

Note: See TracTickets for help on using tickets.