Opened 7 weeks ago

Closed 5 weeks ago

#60512 closed defect (duplicate)

installing cdo failed due to deprecated.cxx11 PortGroup

Reported by: boervu Owned by: tenomoto (Takeshi Enomoto)
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc: boervu
Port: cdo

Description (last modified by mf2k (Frank Schima))

When installing cdo using Macports (OSX 10.14.6 Xcode 10.3) I get the following warning, resulting in a failure of installing cdo:

Warning: -----------------------------------------------------------------------
Warning: The port 'cdo' uses the cxx11 PortGroup which is deprecated.
Warning: Please instead specify the required c++ standard directly using
Warning:     compiler.cxx_standard  2011
Warning: replacing 2011 with newer standards (e.g. 2014, 2017) as required.
Warning: For more details see https://trac.macports.org/wiki/CompilerSelection
Warning: -----------------------------------------------------------------------

Tried to work around it by manually installing cdo, but get the same message, and basically the installation works the same as using macports.

Attachments (1)

main.log (91.5 KB) - added by boervu 7 weeks ago.
main.log after 'sudo port install cdo'

Download all attachments as: .zip

Change History (8)

comment:1 Changed 7 weeks ago by mf2k (Frank Schima)

The Milestone field is for use by Macports team members only, please do not set it.

In the future, please use WikiFormatting and add the port maintainer(s) to Cc (port info --maintainers cdo), if any.

comment:2 Changed 7 weeks ago by mf2k (Frank Schima)

Description: modified (diff)
Keywords: cxx11 removed
Milestone: MacPorts 2.6.3
Owner: set to tenomoto
Status: newassigned

comment:3 Changed 7 weeks ago by boervu

Cc: boervu added

comment:4 Changed 7 weeks ago by mf2k (Frank Schima)

That's simply a warning and not the actual error. Please attach the main.log file.

Changed 7 weeks ago by boervu

Attachment: main.log added

main.log after 'sudo port install cdo'

comment:5 Changed 7 weeks ago by mf2k (Frank Schima)

Error is:

:info:configure configure: error: could not determine ar interface
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_cdo/cdo/work/cdo-1.9.8" && ./configure --prefix=/opt/local --with-netcdf=/opt/local --disable-dependency-tracking --disable-openmp --with-proj=/opt/local/lib/proj5 --with-hdf5=/opt/local --with-udunits2=/opt/local --with-fftw3 --with-curl=/opt/local --with-zlib=/opt/local --with-eccodes=/opt/local --disable-cgribex

comment:6 Changed 7 weeks ago by reneeotten (Renee Otten)

duplicate of 57609

comment:7 Changed 5 weeks ago by tenomoto (Takeshi Enomoto)

Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.