#60633 closed defect (fixed)

py-scipy: error: thread-local storage is not supported for the current target

Reported by: ryandesign (Ryan Schmidt) Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: yosemite Cc:
Port: py-scipy

Description

It's a long logfile containing many other ports' builds, but py-scipy fails with:

In file included from scipy/fft/_pocketfft/pypocketfft.cxx:19:
scipy/fft/_pocketfft/pocketfft_hdronly.h:732:1: error: thread-local storage is not supported for the current target
thread_local size_t thread_id = 0;
^
scipy/fft/_pocketfft/pocketfft_hdronly.h:733:1: error: thread-local storage is not supported for the current target
thread_local size_t num_threads = 1;
^

Maybe this can be made to work using compiler.thread_local_storage yes.

Change History (2)

comment:1 Changed 11 months ago by reneeotten (Renee Otten)

this is a duplicate of #60548. The port already has the statement you suggested, but that's not enough as discussed in the other ticket.

Last edited 11 months ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:2 Changed 11 months ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

In c8ee1c4af31ba4bfde234104e7a11cfea2bbf930/macports-ports (master):

py-scipy: Blacklist clang < 800

Closes: #60548
Closes: #60633

Note: See TracTickets for help on using tickets.