Opened 13 days ago

Closed 12 days ago

Last modified 12 days ago

#60724 closed defect (duplicate)

gnucash @3.9: Could NOT find Threads (missing: Threads_FOUND)

Reported by: posita (Matt Bogosian (formerly @mbogosian)) Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc:
Port: gnucash

Description

% sudo port -N -c install \gnucash
Password:
--->  Computing dependencies for gnucash
--->  Fetching distfiles for gnucash
--->  Attempting to fetch gnucash-3.9.tar.bz2 from https://ayera.dl.sourceforge.net/gnucash
--->  Verifying checksums for gnucash
--->  Extracting gnucash
--->  Configuring gnucash
Warning: -----------------------------------------------------------------------
Warning: The port 'gnucash' uses the cxx11 PortGroup which is deprecated.
Warning: Please instead specify the required c++ standard directly using
Warning:     compiler.cxx_standard  2011
Warning: replacing 2011 with newer standards (e.g. 2014, 2017) as required.
Warning: For more details see https://trac.macports.org/wiki/CompilerSelection
Warning: -----------------------------------------------------------------------
Error: Failed to configure gnucash: configure failure: command execution failed
Error: See /opt/local/macports-20200625/var/macports/logs/_opt_local_macports-20200625_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_gnome_gnucash/gnucash/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug

After reading wiki:CompilerSelection, it's still unclear what action to take as a user. Is that something I can do as a command line parameter or environment variable passed to port install …? All the applicable instructions seem to recommend Portfile modifications.

Attachments (1)

main.log (544.4 KB) - added by posita (Matt Bogosian (formerly @mbogosian)) 13 days ago.

Download all attachments as: .zip

Change History (5)

Changed 13 days ago by posita (Matt Bogosian (formerly @mbogosian))

Attachment: main.log added

comment:1 Changed 12 days ago by kencu (Ken)

That warning is of use for Portfile developers, and is obviously just confusing for users. Apologies for that.

The issue seems to be:

6835	:info:configure -- Looking for pthread.h - found
6836	:info:configure -- Performing Test CMAKE_HAVE_LIBC_PTHREAD
6837	:info:configure -- Performing Test CMAKE_HAVE_LIBC_PTHREAD - Failed
6838	:info:configure -- Check if compiler accepts -pthread
6839	:info:configure -- Check if compiler accepts -pthread - no
6840	:info:configure -- Looking for pthread_create in pthreads
6841	:info:configure -- Looking for pthread_create in pthreads - not found
6842	:info:configure -- Looking for pthread_create in pthread
6843	:info:configure -- Looking for pthread_create in pthread - not found
6844	:info:configure CMake Error at /opt/local/macports-20200625/share/cmake-3.17/Modules/FindPackageHandleStandardArgs.cmake:164 (message):
6845	:info:configure   Could NOT find Threads (missing: Threads_FOUND)
6846	:info:configure Call Stack (most recent call first):
6847	:info:configure   /opt/local/macports-20200625/share/cmake-3.17/Modules/FindPackageHandleStandardArgs.cmake:445 (_FPHSA_FAILURE_MESSAGE)
6848	:info:configure   /opt/local/macports-20200625/share/cmake-3.17/Modules/FindThreads.cmake:234 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
6849	:info:configure   common/cmake_modules/GncAddTest.cmake:126 (find_package)
6850	:info:configure   CMakeLists.txt:636 (gnc_gtest_configure)
6851	:info:configure -- Configuring incomplete, errors occurred!
6852	:info:configure See also "/opt/local/macports-20200625/var/macports/build/_opt_local_macports-20200625_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_gnome_gnucash/gnucash/work/build/CMakeFiles/CMakeOutput.log".
6853	:info:configure See also "/opt/local/macports-20200625/var/macports/build/_opt_local_macports-20200625_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_gnome_gnucash/gnucash/work/build/CMakeFiles/CMakeError.log".
6854	:info:configure Command failed:  cd "/opt/local/macports-20200625/var/macports/build/_opt_local_macports-20200625_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_gnome_gnucash/gnucash/work/build" && /opt/local/macports-20200625/bin/cmake -G "CodeBlocks - Unix Makefiles" -DCMAKE_BUILD_TYPE=MacPorts -DCMAKE_INSTALL_PREFIX="/opt/local/macports-20200625" -DCMAKE_INSTALL_NAME_DIR="/opt/local/macports-20200625/lib" -DCMAKE_SYSTEM_PREFIX_PATH="/opt/local/macports-20200625;/usr" -DCMAKE_C_COMPILER="$CC" -DCMAKE_CXX_COMPILER="$CXX" -DCMAKE_POLICY_DEFAULT_CMP0025=NEW -DCMAKE_POLICY_DEFAULT_CMP0060=NEW -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_COLOR_MAKEFILE=ON -DCMAKE_FIND_FRAMEWORK=LAST -DCMAKE_EXPORT_COMPILE_COMMANDS=ON -DCMAKE_MAKE_PROGRAM=/usr/bin/make -DCMAKE_MODULE_PATH="/opt/local/macports-20200625/share/cmake/Modules" -DCMAKE_PREFIX_PATH="/opt/local/macports-20200625/share/cmake/Modules" -DCMAKE_BUILD_WITH_INSTALL_RPATH:BOOL=ON -DCMAKE_INSTALL_RPATH="/opt/local/macports-20200625/lib" -Wno-dev -DENABLE_BINRELOC=OFF -DCMAKE_INSTALL_SYSCONFDIR=/opt/local/macports-20200625/etc -DWITH_PYTHON=ON -DPYTHON_EXECUTABLE:FILEPATH=/opt/local/macports-20200625/bin/python3.6 -DPYTHON_INCLUDE_DIR:PATH=/Library/Frameworks/MacPorts-20200625/Python.framework/Versions/3.6/include/python3.6m -DPYTHON_LIBRARY:FILEPATH=/Library/Frameworks/MacPorts-20200625/Python.framework/Versions/3.6/lib/libpython3.6.dylib -DCMAKE_OSX_ARCHITECTURES="x86_64" -DCMAKE_OSX_DEPLOYMENT_TARGET="10.15" -DCMAKE_OSX_SYSROOT="/Library/Developer/CommandLineTools/SDKs/MacOSX10.15.sdk" /opt/local/macports-20200625/var/macports/build/_opt_local_macports-20200625_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_gnome_gnucash/gnucash/work/gnucash-3.9
6855	:info:configure Exit code: 1

and what really is going wrong is probably indicated in those two other log files listed uner See also.

comment:2 Changed 12 days ago by ryandesign (Ryan Schmidt)

Cc: dports@… removed
Owner: set to drkp
Status: newassigned
Summary: gnucash fails to build ("uses the cxx11 PortGroup which is deprecated")gnucash @3.9: Could NOT find Threads (missing: Threads_FOUND)

comment:3 Changed 12 days ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Duplicate of #60310.

comment:4 in reply to:  1 Changed 12 days ago by ryandesign (Ryan Schmidt)

Replying to kencu:

That warning is of use for Portfile developers, and is obviously just confusing for users. Apologies for that.

Yeah. We need a developer mode.

Note: See TracTickets for help on using tickets.