Opened 4 months ago

Closed 4 weeks ago

#60770 closed defect (fixed)

webkit2-gtk: Could NOT find PerlModules_JSON::PP

Reported by: ryandesign (Ryan Schmidt) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc: kencu (Ken)
Port: webkit2-gtk

Description

https://build.macports.org/builders/ports-10.6_x86_64-builder/builds/29531/steps/install-dependencies/logs/stdio

-- Found Perl: /usr/bin/perl (found suitable version "5.10.0", minimum required is "5.10.0") 
-- Could NOT find PerlModules_JSON::PP (missing: PerlModules_JSON_PP_FOUND) 
CMake Error at /opt/local/share/cmake-3.17/Modules/FindPackageHandleStandardArgs.cmake:164 (message):
  Could NOT find PerlModules (missing: PerlModules_all_modules_found
  JSON::PP)

Change History (2)

comment:1 Changed 4 months ago by kencu (Ken)

Isn't it just a miracle that I can make this work on 10.6 at all?

I wonder how long I will be able to keep up the magic. Getting pretty tricky.

This one looks totally trivial, thankfully -- spec a perl and I guess a perl module it wants.

Last edited 4 months ago by kencu (Ken) (previous) (diff)

comment:2 Changed 4 weeks ago by kencu (Ken)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.