Opened 10 months ago

Last modified 5 months ago

#60821 accepted request

Please add cegui 0.8.x

Reported by: programmingkidx Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: programmingkidx
Port: cegui

Description (last modified by programmingkidx)

There are games that require cegui 0.7.x and others that require cegui 0.8.x. I suggest cegui 0.8.x be added to MacPorts and we continue offering version 0.7.x.

Change History (11)

comment:1 Changed 10 months ago by programmingkidx

Cc: programmingkidx added

comment:2 Changed 10 months ago by ryandesign (Ryan Schmidt)

Cc: yandesign@… removed
Owner: set to ryandesign
Status: newaccepted
Type: defectrequest

I see. Well, it remains to be seen whether cegui 0.7 will remain compatible with libdevil 1.8.0. If so, sure, we could offer both.

comment:3 Changed 10 months ago by programmingkidx

Description: modified (diff)

comment:4 Changed 10 months ago by programmingkidx

I suggest using CEGUI 0.8.4. This version still has the OpenGL library targets.

comment:5 Changed 10 months ago by ryandesign (Ryan Schmidt)

0.8.4 is 6 years old. 0.8.7 is the latest and is 4 years old; surely we should use that.

comment:6 Changed 10 months ago by programmingkidx

There is a game I am trying to port that does look for the file libCEGUIOpenGLRenderer-0.dylib. I think version 0.8.4 is the last version the allow the building of this library. I saw no mention of the library in 0.8.7.

comment:7 Changed 10 months ago by ryandesign (Ryan Schmidt)

According to the cegui website news entries, 0.8.x is a stable branch. You should be able to develop a game with any 0.8.x version and substitute any later 0.8.x version and have it still work. So they can't have removed libCEGUIOpenGLRenderer-0.dylib or anything else. The only exception is 0.8.4, which inadvertently removed a symbol. It was returned in 0.8.5. So the only version of the 0.8.x branch that we should not consider offering is 0.8.4.

I built 0.8.7 on my system and it does provide libCEGUIOpenGLRenderer-0.dylib.

comment:8 Changed 10 months ago by programmingkidx

I stand corrected. Perhaps 0.8.7 is what should be used.

comment:9 Changed 9 months ago by programmingkidx

Any updates?

comment:10 Changed 9 months ago by programmingkidx

I would like to note that I built CEGUI with clang 5.1, clang 10, and gcc 10. Only the clang 10 version worked correctly.

Is there anything I could do to help with this port?

comment:11 Changed 5 months ago by programmingkidx

It has been a while since the last updated. Just use CMake to create an Xcode project. Then build the project in Xcode.

Note: See TracTickets for help on using tickets.