Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#60930 closed defect (fixed)

gpgme @1.14.0: error: use of undeclared identifier 'getenv'

Reported by: macuserguru Owned by: lbschenkel (Leonardo Brondani Schenkel)
Priority: Normal Milestone:
Component: ports Version: 2.6.3
Keywords: Cc: macuserguru, dbevans (David B. Evans), chrstphrchvz (Christopher Chavez)
Port: gpgme

Description

Failed to build gpgme: command execution failed

$ sudo /opt/local/bin/port upgrade outdated
--->  Computing dependencies for gpgme
--->  Fetching archive for gpgme
--->  Attempting to fetch gpgme-1.14.0_0.darwin_15.x86_64.tbz2 from https://packages.macports.org/gpgme
--->  Attempting to fetch gpgme-1.14.0_0.darwin_15.x86_64.tbz2 from https://lil.fr.packages.macports.org/gpgme
--->  Attempting to fetch gpgme-1.14.0_0.darwin_15.x86_64.tbz2 from https://mse.uk.packages.macports.org/gpgme
--->  Fetching distfiles for gpgme
--->  Attempting to fetch gpgme-1.14.0.tar.bz2 from https://distfiles.macports.org/gpgme
--->  Verifying checksums for gpgme
--->  Extracting gpgme
--->  Applying patches to gpgme
--->  Configuring gpgme
--->  Building gpgme
Error: Failed to build gpgme: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_gpgme/gpgme/main.log for details.

Attachments (1)

main.log (159.1 KB) - added by macuserguru 16 months ago.

Download all attachments as: .zip

Change History (9)

Changed 16 months ago by macuserguru

Attachment: main.log added

comment:1 Changed 16 months ago by macuserguru

Cc: macuserguru added

comment:2 Changed 16 months ago by ryandesign (Ryan Schmidt)

Cc: dbevans added
Owner: set to lbschenkel
Port: gpgme added
Status: newassigned
Summary: Failed to build gpgme: command execution failedgpgme @1.14.0: error: use of undeclared identifier 'getenv'
Version: 2.6.3

comment:3 Changed 16 months ago by chrstphrchvz (Christopher Chavez)

This error is reproduced by the 10.8-10.11 builders: https://ports.macports.org/port/gpgme/summary

comment:4 Changed 16 months ago by chrstphrchvz (Christopher Chavez)

Cc: chrstphrchvz added

comment:5 Changed 16 months ago by jmroot (Joshua Root)

Resolution: fixed
Status: assignedclosed

In c4747c7780626743a7604a88ff6a33d862df1b8b/macports-ports (master):

gpgme: fix build failure due to missing include

Fixes: #60930

comment:6 Changed 16 months ago by jmroot (Joshua Root)

Maintainers, please send this fix upstream.

comment:7 Changed 16 months ago by lbschenkel (Leonardo Brondani Schenkel)

Thank you for looking at this. I can see that this was already reported upstream at https://dev.gnupg.org/T5013.

comment:8 Changed 16 months ago by macuserguru

Thanks - works now! :-)

Note: See TracTickets for help on using tickets.