Opened 8 weeks ago

Last modified 6 weeks ago

#60982 reopened defect

MacPorts installation fails - OSX SIerra 10.12.6 - Xcode 9.2 - CLT

Reported by: iriann Owned by:
Priority: Normal Milestone:
Component: base Version: 2.6.3
Keywords: Cc:
Port:

Description

The installer fails to complete with following message:

"The installer encountered and error that caused the installation to fail. Contact the software manufacturer for assistance."

I did follow the installation guide steps on site.

Attachments (3)

Installer Log 9-Aug-2020.txt (9.0 KB) - added by iriann 8 weeks ago.
Installer Log 9-Aug-2020.2.txt (9.0 KB) - added by iriann 7 weeks ago.
install.log-21-Aug-2020.txt (8.6 KB) - added by mikeyearworth 6 weeks ago.
Installation Log

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 weeks ago by ryandesign (Ryan Schmidt)

Keywords: installation error removed

Can you provide an installation log file that shows what went wrong?

Go through the installation again. If it fails again, from the Window menu, choose Installer Log. Click Save in that window, save the log to a file, and attach it to this ticket.

Changed 8 weeks ago by iriann

comment:2 Changed 8 weeks ago by ryandesign (Ryan Schmidt)

The part where it says

An error occurred while extracting files from the package “MacPorts-2.6.3-10.12-Sierra.pkg”.

cpio read error: bad file format

makes me think that you have a corrupted download. Would you try deleting MacPorts-2.6.3-10.12-Sierra.pkg and downloading a fresh copy from https://distfiles.macports.org/MacPorts/?

comment:3 Changed 7 weeks ago by iriann

I did what you said but installer returns the same error as before.

Changed 7 weeks ago by iriann

comment:4 Changed 7 weeks ago by jmroot (Joshua Root)

The pkg is signed, so Installer would fail to verify the signature right at the start if it had been modified.

comment:5 Changed 7 weeks ago by iriann

i moved the download file to different location (from downloads folder to desktop) and the installer was writing packages but stuck for too long hour and i force quit it.

comment:6 Changed 7 weeks ago by iriann

After reboot, re-download the installer, moving it to desktop and run it from there, installer completed successfully. I am not sure which was the problem exactly (corrupt download/execution location of installer) but I report the steps I took if someone is facing the same problem in the future.

Thank you Joshua Root for you help and your time.

comment:7 Changed 7 weeks ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

Glad you got it working. The only other suggestion I could think of was that maybe there is something wrong with your disk; you might want to open Disk Utility and run First Aid just to make sure.

Changed 6 weeks ago by mikeyearworth

Attachment: install.log-21-Aug-2020.txt added

Installation Log

comment:8 Changed 6 weeks ago by mikeyearworth

Resolution: worksforme
Status: closedreopened

I have been able to reproduce this problem trying to install MacPorts-2.6.3-10.12-Sierra.pkg onto macOS 10.12.6 with Xcode 9.3 with CLT. I tried a few times from ~/Downloads and then ~/Desktop. Same problem every time. I have just run First Aid and found 0 errors.

Aug 21 15:19:34 iMac installd[353]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=110 "An error occurred while extracting files from the package “MacPorts-2.6.3-10.12-Sierra.pkg”." UserInfo={NSUnderlyingError=0x7fac3af91a60 {Error Domain=BOMCopierFatalError Code=1 "cpio read error: bad file format"

See install.log-21-Aug-2020.txt for the whole installation log.

comment:9 Changed 6 weeks ago by mikeyearworth

This is now FYI

I have now performed a Git Install, which worked fine and I'm up and running.

Note: See TracTickets for help on using tickets.