Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#61030 closed defect (duplicate)

Error updating Curl

Reported by: knightjp Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: chrstphrchvz (Christopher Chavez)
Port: curl

Description

Attempted to do a "sudo port upgrade outdated" and this is what happened.

--->  Fetching archive for curl-ca-bundle
--->  Attempting to fetch curl-ca-bundle-7.72.0_0.darwin_19.noarch.tbz2 from https://lil.fr.packages.macports.org/curl-ca-bundle
--->  Attempting to fetch curl-ca-bundle-7.72.0_0.darwin_19.noarch.tbz2.rmd160 from https://lil.fr.packages.macports.org/curl-ca-bundle
--->  Installing curl-ca-bundle @7.72.0_0
--->  Cleaning curl-ca-bundle
--->  Deactivating curl-ca-bundle @7.71.1_0
--->  Cleaning curl-ca-bundle
--->  Activating curl-ca-bundle @7.72.0_0
--->  Cleaning curl-ca-bundle
--->  Computing dependencies for curl
--->  Fetching archive for curl
--->  Attempting to fetch curl-7.72.0_0+ssl.darwin_19.x86_64.tbz2 from https://lil.fr.packages.macports.org/curl
--->  Attempting to fetch curl-7.72.0_0+ssl.darwin_19.x86_64.tbz2 from http://nue.de.packages.macports.org/curl
--->  Attempting to fetch curl-7.72.0_0+ssl.darwin_19.x86_64.tbz2 from https://mse.uk.packages.macports.org/curl
--->  Fetching distfiles for curl
--->  Attempting to fetch curl-7.72.0.tar.xz from https://curl.haxx.se/download/
--->  Verifying checksums for curl
--->  Extracting curl
--->  Applying patches to curl
Error: Failed to patch curl: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_net_curl/curl/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.

Change History (7)

comment:1 Changed 14 months ago by rjdave

I ran into this too. The issue is that curl version 7.72.0 already has libressl.patch applied. Patch recognizes this and skips it but when a patch is skipped as a duplicate, patch returns an exit status of 1 so macports thinks the patch failed.

The way I got around this was to attempt a normal install and let it fail. Then go to the source code and undo the patch to config (set link_all_deplibs=yes on line ~13098) and make line ~621 of lib/vtls/openssl.c:

#if (OPENSSL_VERSION_NUMBER >= 0x1000200fL) /* 1.0.2 or later */

and remove the next 2 lines so the patches can be applied successfully during the next port install attempt.

Last edited 14 months ago by rjdave (previous) (diff)

comment:2 Changed 14 months ago by gaming-hacker (G Alexander)

I just disabled the patch file in the Portfile

patchfiles configure.patch

# libressl.patch

comment:3 Changed 14 months ago by bdbaddog

I'm seeing the same.

comment:4 Changed 14 months ago by chrstphrchvz (Christopher Chavez)

Duplicate of #61025 (fixed in [ce2a7eea7a/macports-ports]). This can be closed.

comment:5 Changed 14 months ago by chrstphrchvz (Christopher Chavez)

Cc: chrstphrchvz added

comment:6 Changed 14 months ago by tobypeterson

Resolution: duplicate
Status: newclosed

comment:7 Changed 14 months ago by mf2k (Frank Schima)

Port: curl added; Curl removed
Type: updatedefect
Note: See TracTickets for help on using tickets.