Opened 2 years ago

Last modified 23 months ago

#61053 assigned defect

py27-pygit2 needs compatible of libgit2 after libgit2 update today

Reported by: snowflake (Dave Evans) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.6.99
Keywords: Cc: raimue (Rainer Müller), chrstphrchvz (Christopher Chavez)
Port: py-pygit2

Description

from the log

creating build/temp.macosx-10.11-x86_64-2.7/src
/usr/bin/clang -fno-strict-aliasing -fno-common -dynamic -pipe -Os -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -isysroot/ -I/usr/local/include -I/opt/local/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c src/blob.c -o build/temp.macosx-10.11-x86_64-2.7/src/blob.o
In file included from src/blob.c:30:
In file included from src/blob.h:34:
src/types.h:36:2: error: You need a compatible libgit2 version (v0.28.x)
#error You need a compatible libgit2 version (v0.28.x)
 ^

Change History (8)

comment:1 Changed 2 years ago by ryandesign (Ryan Schmidt)

Cc: dbevans raimue added

We would either have to add a new port for libgit2 0.28.x or remove py27-pygit2. (The newer py3x-pygit2 subports hopefully already support the newer libgit2.) Removing py27-pygit2 is probably what I would suggest given what python27 is EOL but it would impact gitless which depends on it. Maybe gitless can be updated to use py3x-pygit2.

comment:2 in reply to:  1 Changed 2 years ago by dbevans (David B. Evans)

Replying to ryandesign:

We would either have to add a new port for libgit2 0.28.x or remove py27-pygit2. (The newer py3x-pygit2 subports hopefully already support the newer libgit2.) Removing py27-pygit2 is probably what I would suggest given what python27 is EOL but it would impact gitless which depends on it. Maybe gitless can be updated to use py3x-pygit2.

+1

pygit2 v1.0.0 dropped support for py27 and py34 and v1.2.0 pygit2 only supports py36+ so the py35 subport should be removed as well.

comment:3 Changed 2 years ago by dbevans (David B. Evans)

Last edited 2 years ago by dbevans (David B. Evans) (previous) (diff)

comment:4 Changed 2 years ago by dbevans (David B. Evans)

See https://github.com/macports/macports-ports/pull/8221 for my draft PR for discussion.

comment:5 Changed 2 years ago by dbevans (David B. Evans)

In 2b5306d8906e988b8401f9a3cdfc05ca41a14346/macports-ports (master):

py-pygit2: drop py27 py35 subports

Current version only supports python 3.6+ and pypy3 7.2+.

See #61053

comment:6 Changed 23 months ago by chrstphrchvz (Christopher Chavez)

gitless was migrated to py38-pygit2: [5e0a4cd299/macports-ports]. I believe this can be closed.

comment:7 Changed 23 months ago by chrstphrchvz (Christopher Chavez)

Cc: chrstphrchvz added

comment:8 Changed 23 months ago by mf2k (Frank Schima)

Cc: dbevans removed
Owner: set to dbevans
Status: newassigned

This is David's port. Let's see if he agrees.

Note: See TracTickets for help on using tickets.