Opened 7 months ago

Closed 7 months ago

#61114 closed defect (duplicate)

orc-0.4.31_0+universal: Failed to destroot orc: command execution failed

Reported by: qiet72 Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.3
Keywords: Cc:
Port: orc

Description

Doing "sudo port -N install wine" fails when installing package orc.
Here is the environment information:

:info:destroot Command '['install_name_tool', '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_orc/orc/work/destroot/opt/local/lib/liborc-test-0.4.0.dylib', '-id', '/opt/local/lib/liborc-test-0.4.0.dylib', '-change', '@rpath/liborc-0.4.0.dylib', '/opt/local/lib/liborc-0.4.0.dylib', '-change', '@rpath/liborc-test-0.4.0.dylib', '/opt/local/lib/liborc-test-0.4.0.dylib']' returned non-zero exit status 1.
:info:destroot FAILED: meson-install 
:info:destroot /opt/local/Library/Frameworks/Python.framework/Versions/3.8/bin/meson install --no-rebuild
:info:destroot ninja: build stopped: subcommand failed.
:info:destroot Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_orc/orc/work/build" && /opt/local/bin/ninja install 
:info:destroot Exit code: 1
:error:destroot Failed to destroot orc: command execution failed
:debug:destroot Error code: CHILDSTATUS 4448 1
:debug:destroot Backtrace: command execution failed
:debug:destroot     while executing
:debug:destroot "system {*}$notty {*}$nice $fullcmdstring"
:debug:destroot     invoked from within
:debug:destroot "command_exec destroot"
:debug:destroot     (procedure "portdestroot::destroot_main" line 2)
:debug:destroot     invoked from within
:debug:destroot "$procedure $targetname"
:error:destroot See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_orc/orc/main.log for details.
bash-3.2$ port info orc
orc @0.4.31 (devel)
Variants:             universal

Description:          Orc is a library and set of tools for compiling and executing very simple
                      programs that operate on arrays of data.
Homepage:             https://gstreamer.freedesktop.org/modules/orc.html

Extract Dependencies: xz
Build Dependencies:   meson, ninja
Platforms:            darwin
License:              BSD
Maintainers:          none
bash-3.2$ sw_vers 
ProductName:    Mac OS X
ProductVersion: 10.10.5
BuildVersion:   14F2511
bash-3.2$ xcodebuild -version
Xcode 7.2.1
Build version 7C1002
bash-3.2$ clang -v
Apple LLVM version 7.0.2 (clang-700.1.81)
Target: x86_64-apple-darwin14.5.0
Thread model: posix
bash-3.2$ /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -v
Apple LLVM version 7.0.2 (clang-700.1.81)
Target: x86_64-apple-darwin14.5.0
Thread model: posix

Attachments (1)

main.log (98.2 KB) - added by qiet72 7 months ago.
Error log

Download all attachments as: .zip

Change History (2)

Changed 7 months ago by qiet72

Attachment: main.log added

Error log

comment:1 Changed 7 months ago by mf2k (Frank Schima)

Resolution: duplicate
Status: newclosed

Duplicate of #60352.

Note: See TracTickets for help on using tickets.