Opened 7 months ago

Last modified 7 months ago

#61172 assigned defect

llvm-3.3: needs a newer python to build on older systems

Reported by: TzunamiOSX Owned by: kencu (Ken)
Priority: Normal Milestone:
Component: ports Version: 2.6.3
Keywords: leopard powerpc Cc: jeremyhu (Jeremy Huddleston Sequoia), larryv (Lawrence Velázquez), kencu (Ken)
Port: llvm-3.3

Description (last modified by kencu (Ken))

i want to upgrade (G5) and install ffmpeg (iMac G4) for around 2 weaks and i get error over error. Now it is llvm-3.3-3.3 before juli, the problems were minimal, but in the last weaks i must cry every day, because i must write bug reports ;)

by the way, were is the owner field?

Error: Failed to configure llvm-3.3, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_llvm-3.3/llvm-3.3/work/build/config.log
Error: Failed to configure llvm-3.3: configure failure: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_llvm-3.3/llvm-3.3/main.log for details.

Attachments (1)

llvm-3.3-3.3_11.darwin_9.ppc (55.2 KB) - added by TzunamiOSX 7 months ago.
main.log

Download all attachments as: .zip

Change History (9)

Changed 7 months ago by TzunamiOSX

main.log

comment:1 Changed 7 months ago by kencu (Ken)

I'm sorry that I have not fixed this ancient llvm-3.3 python bug

For right now, please do this:

sudo port -v install python27
sudo port -v select python python27

and then clean and try your build of llvm-3.3 again and you should be good to go.

I will fix that llvm-3.3 python bug soonishly.

comment:2 Changed 7 months ago by kencu (Ken)

Description: modified (diff)
Owner: set to kencu
Status: newassigned
Summary: llvm-3.3-3.3_11.darwin_9.ppc error on upgradellvm-3.3: needs a newer python to build on TIger

comment:3 Changed 7 months ago by kencu (Ken)

Summary: llvm-3.3: needs a newer python to build on TIgerllvm-3.3: needs a newer python to build on older systems

comment:4 Changed 7 months ago by kencu (Ken)

Port: llvm-3.3 added; llvm-3.3-3.3_11.darwin_9.ppc removed

comment:5 Changed 7 months ago by mf2k (Frank Schima)

Keywords: leopard, powerpcleopard powerpc

comment:6 Changed 7 months ago by TzunamiOSX

Thanks for help kencu :)

comment:7 Changed 7 months ago by kencu (Ken)

has dup #61198

comment:8 Changed 7 months ago by kencu (Ken)

see also #60781 (same train, different track).

Last edited 7 months ago by kencu (Ken) (previous) (diff)
Note: See TracTickets for help on using tickets.