Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#61198 closed defect (duplicate)

llvm-3.3 @3.3_11 does not rebuild on PPC Leopard, Mac OS X 10.5.8, after upgrading libffi

Reported by: ballapete (Peter Dyballa) Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.3
Keywords: leopard Cc: jeremyhu@…, larryv@…, kencu@…
Port: llvm-3.3

Description

checking for python... /opt/local/bin/python
checking for python >= 2.5...   File "<string>", line 1
    import sys; print sys.version.split()[0]
                      ^
SyntaxError: invalid syntax
/opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_lang_llvm-3.3/llvm-3.3/work/llvm-3.3.src/configure: line 12394: test: : integer expression expected
not found
configure: error: found python  (/opt/local/bin/python); required >= 2.5
See `config.log' for more details.
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_lang_llvm-3.3/llvm-3.3/work/build" && /opt/local/var/macports/build/_opt_local_var_macports_sources_nue.de.rsync.macports.org_macports_release_tarballs_ports_lang_llvm-3.3/llvm-3.3/work/llvm-3.3.src/configure --build=powerpc-apple-darwin9 --enable-bindings=none --enable-libffi --enable-shared --enable-jit --enable-optimized --disable-profiling --enable-pic --enable-debug-symbols --disable-debug-runtime --prefix="/opt/local/libexec/llvm-3.3" --disable-assertions --with-optimize-option=-Os 

The rebuild is necessary because libffi was upgraded. /opt/local/bin/python point indeed to Python version 3.8.5 which has problems with the test.

Attachments (4)

main.log (24.4 KB) - added by ballapete (Peter Dyballa) 5 months ago.
Main.log from PPC Leopard
config.log (99.3 KB) - added by ballapete (Peter Dyballa) 5 months ago.
llvm-3.3-configure-patch.diff (3.6 KB) - added by ballapete (Peter Dyballa) 5 months ago.
Proposed patch to work with any of MacPorts' Python versions on old Macs (and solve reports about a '-pipe' command that does not exist)
main.2.log (3.7 MB) - added by ballapete (Peter Dyballa) 5 months ago.
Main.log from Catalina with Python 3.8.5 – failure

Change History (12)

Changed 5 months ago by ballapete (Peter Dyballa)

Attachment: main.log added

Main.log from PPC Leopard

Changed 5 months ago by ballapete (Peter Dyballa)

Attachment: config.log added

comment:1 Changed 5 months ago by ballapete (Peter Dyballa)

Selecting python27 lets the configure step pass. llvm-3.4 @3.4.2_13 (active) platform='darwin 9' archs='ppc' date='2020-09-17T13:01:16+0200' obviously can be built with Python 3.8.5.

comment:2 Changed 5 months ago by ballapete (Peter Dyballa)

In llvm-3.4 the configure ckeck for Python is simply patched away – wouldn't this work for llvm-3.3 as well? (llvm-3.3's configure script has on lines # 1990 and 1991 bugs: The lines should start with ": ".)

Last edited 5 months ago by ballapete (Peter Dyballa) (previous) (diff)

comment:3 Changed 5 months ago by ballapete (Peter Dyballa)

The attached patch should resolve the problems – not tested yet because port is rebuilding other ports… (Maybe on the weekend!)

Changed 5 months ago by ballapete (Peter Dyballa)

Proposed patch to work with any of MacPorts' Python versions on old Macs (and solve reports about a '-pipe' command that does not exist)

comment:4 Changed 5 months ago by kencu (Ken)

Resolution: duplicate
Status: newclosed

thanks for the info and patch, Peter.This turns out to be a duplicate of #61172.

comment:5 in reply to:  4 Changed 5 months ago by ballapete (Peter Dyballa)

Replying to kencu:

This turns out to be a duplicate of #61172.

I've seen this report but assumed it was about a variant…

Changed 5 months ago by ballapete (Peter Dyballa)

Attachment: main.2.log added

Main.log from Catalina with Python 3.8.5 – failure

comment:6 in reply to:  3 ; Changed 5 months ago by ballapete (Peter Dyballa)

Tested this patch on Catalina with Python 3.8.5: failure. Selecting python27-apple as python lead to success. (make check seems to have been successful too.) Selecting python38 for python again and adding --with-python=${prefix}/bin/python2.7 to configure.args lead to the same failure as before – because there was no code to handle this additional configure argument. Not applying my patch lead to success again – in the presence of the additional configure argument --with-python=${prefix}/bin/python2.7. (make check seems to have been successful too.)

The best effort should be to add a dependency to python27 and add --with-python=${prefix}/bin/python2.7 as an unconditional configure argument.

comment:7 in reply to:  6 Changed 5 months ago by kencu (Ken)

Replying to ballapete:

The best effort should be to add a dependency to python27 and add --with-python=${prefix}/bin/python2.7 as an unconditional configure argument.

Thanks! I'll incorporate that into some patches soon. Appreciate your input.

Last edited 5 months ago by kencu (Ken) (previous) (diff)

comment:8 Changed 5 months ago by ballapete (Peter Dyballa)

Last edited 5 months ago by ballapete (Peter Dyballa) (previous) (diff)
Note: See TracTickets for help on using tickets.