Opened 5 months ago

Last modified 5 months ago

#61221 assigned defect

ghc @8.10.1: testing separately fails

Reported by: ryandesign (Ryan Schmidt) Owned by: essandess (Steve Smith)
Priority: Normal Milestone:
Component: ports Version: 2.6.3
Keywords: Cc:
Port: ghc

Description

I built ghc with sudo port build ghc, it completed successfully, and then I tried to test it with sudo port test ghc, which failed:

:debug:test system:  cd "/opt/local/var/macports/build/_Users_rschmidt_macports_macports-ports-ryandesign-fork_lang_ghc/ghc/work/ghc-8.10.1/testsuite" && /usr/bin/make test 
:info:test make: *** No rule to make target `test'.  Stop.

This appears to be because the port sets test.dir within a pre-build block. This block would only run when the build phase is run. If I run the test phase separately from the build phase, as I did above, then that pre-build block will not run. The port needs to be changed so that test.dir is set to the correct value unconditionally, either outside of any block or if it can only be computed at runtime then within a pre-test block.

Attachments (1)

main.log (4.5 KB) - added by ryandesign (Ryan Schmidt) 5 months ago.

Download all attachments as: .zip

Change History (3)

Changed 5 months ago by ryandesign (Ryan Schmidt)

Attachment: main.log added

comment:2 Changed 5 months ago by essandess (Steve Smith)

In ab891551d4693be90aa6492b0f4e5b8d98cebf29/macports-ports (master):

ghc: Bugfixes for test and iconv linking

Fixes:

Note: See TracTickets for help on using tickets.