Opened 7 months ago

Last modified 2 months ago

#61233 assigned defect

port command hangs under tracemode

Reported by: chrstphrchvz (Christopher Chavez) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 2.6.3
Keywords: tracemode Cc:
Port:

Description (last modified by chrstphrchvz (Christopher Chavez))

Example: configuring openmpi-default @4.0.1_1 under trace mode hangs indefinitely (0% CPU) following this output:

checking if cmpxchg16b_result works... no
checking for assembly architecture... X86_64
checking for builtin atomics... BUILTIN_GCC

*** Fortran compiler
checking whether we are using the GNU Fortran compiler... yes
checking whether /opt/local/bin/gfortran-mp-10 accepts -g... yes
checking whether ln -s works... yes

Interrupting with ctrl-c prints:

^Cchecking if Fortran compiler works...
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_github.com_macports_macports-ports_science_openmpi/openmpi-default/work/build" && /opt/local/var/macports/build/_opt_local_var_macports_sources_github.com_macports_macports-ports_science_openmpi/openmpi-default/work/openmpi-4.0.1/configure --prefix=/opt/local --enable-mpi-fortran --enable-mpi-cxx FFLAGS='' F77='' --bindir=/opt/local/libexec/openmpi-mp --libdir=/opt/local/lib/openmpi-mp --sysconfdir=/opt/local/etc/openmpi-mp --includedir=/opt/local/include/openmpi-mp --datadir=/opt/local/share/openmpi-mp --docdir=/opt/local/share/docdelete --mandir=/opt/local/share/mandelete --with-hwloc=/opt/local
Exit code: 1
Error: Aborted: SIGINT received.

Change History (10)

comment:1 Changed 3 months ago by mascguy (Christopher Nielsen)

Cc: mascguy added

comment:2 Changed 3 months ago by mascguy (Christopher Nielsen)

I'll take this. Can someone please assign to me?

comment:3 Changed 3 months ago by mascguy (Christopher Nielsen)

Just curious, on which macOS release(s) did you encounter this issue?

comment:4 Changed 3 months ago by chrstphrchvz (Christopher Chavez)

I currently observe the issue under macOS 10.15.7 (19H15). The configure script has since slightly reorganized its output, but the problem is still when checking the Fortran compiler. Using Activity Monitor, I see that gfortran-mp-10 is waiting on a process collect2 which is blocking on a read() call.

comment:5 Changed 3 months ago by mf2k (Frank Schima)

Cc: mascguy removed
Owner: set to mascguy
Status: newassigned

comment:6 Changed 3 months ago by mascguy (Christopher Nielsen)

Given that trace made is inherently intrusive, there is certainly the potential for a situation like this.

I'll take a look, but I'm not sure whether this is fixable. How would you rate this priority-wise?

comment:7 Changed 3 months ago by chrstphrchvz (Christopher Chavez)

Not high priority to me personally, but I believe I may have encountered a similar issue with other ports (and neglected to open additional reports). One might wait a long time before realizing it is stuck, though.

comment:8 Changed 3 months ago by mascguy (Christopher Nielsen)

If you're also seeing this with other unrelated ports, it's a more general issue... and there's no need for additional tickets. Instead, change the summary and description to reflect that, clear the 'port' field, change the 'component' field to "base," and reassign to macports-tickets@….

Last edited 3 months ago by mascguy (Christopher Nielsen) (previous) (diff)

comment:9 Changed 3 months ago by chrstphrchvz (Christopher Chavez)

Component: portsbase
Description: modified (diff)
Owner: changed from mascguy to macports-tickets@…
Port: openmpi-default removed
Summary: openmpi-default: configure hangs under tracemodeport command hangs under tracemode

comment:10 Changed 2 months ago by chrstphrchvz (Christopher Chavez)

I believe R may have been another affected port: #61197

Note: See TracTickets for help on using tickets.