Opened 5 months ago

Closed 3 months ago

Last modified 3 months ago

#61284 closed defect (fixed)

python39 fails build on ARM64

Reported by: michaelld (Michael Dickens) Owned by: jmroot (Joshua Root)
Priority: Normal Milestone:
Component: ports Version:
Keywords: arm64 Cc: ryandesign (Ryan Schmidt), shibukawa (Yoshiki Shibukawa)
Port: python39

Description

During configuration:

:info:configure checking size of pthread_key_t... 8
:info:configure checking whether pthread_key_t is compatible with int... no
:info:configure configure: error: Unexpected output of 'arch' on OSX

Change History (12)

comment:1 Changed 5 months ago by jmroot (Joshua Root)

Yes, Apple Silicon support is yet to come in a future release.

comment:2 Changed 5 months ago by michaelld (Michael Dickens)

Interesting. So we've managed to patch up Python38 but not Python39 ... OK well I guess any testing of Py39 on ARM64 will just have to wait! Thx for the info.

comment:3 Changed 5 months ago by ryandesign (Ryan Schmidt)

Cc: ryandesign added

comment:4 Changed 5 months ago by ryandesign (Ryan Schmidt)

Owner: set to jmroot
Status: newassigned

I'm pretty surprised Python 3.9.0 shipped without these fixes, considering Apple had sent PRs to the Python developers months ago.

comment:5 Changed 5 months ago by jmroot (Joshua Root)

It looks like 3.8 is also missing most of the Apple Silicon fixes (it has just enough of a patch to compile) and the Big Sur ones as well. Upstream has said they'll put them in a future 3.8 release.

comment:6 Changed 3 months ago by ryandesign (Ryan Schmidt)

Cc: shibukawa added
Keywords: arm64 added

Has duplicate #61595.

comment:7 Changed 3 months ago by jmroot (Joshua Root)

Upstream issue is https://bugs.python.org/issue41100 BTW.

comment:8 Changed 3 months ago by jpanetta (Julian Panetta)

With the commits merged earlier today, the 3.9 branch now builds on ARM64!

comment:9 Changed 3 months ago by michaelld (Michael Dickens)

comment:10 Changed 3 months ago by jmroot (Joshua Root)

Working on the update, might still need a little more patching.

comment:11 Changed 3 months ago by jmroot (Joshua Root)

Resolution: fixed
Status: assignedclosed

In 684bb1311c9a56b3cd5b99ff7c59e996013340ea/macports-ports (master):

python39: update to 3.9.1

Fixes: #61284

comment:12 Changed 3 months ago by shibukawa (Yoshiki Shibukawa)

Thank you. I confirmed it works.

Note: See TracTickets for help on using tickets.