Opened 15 years ago

Closed 15 years ago

#6131 closed defect (duplicate)

BUG: dependency of libgnomeui gnome-keyring not resolved

Reported by: daniel@… Owned by: gnome-darwinports@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

I am in the process of building monodoc. While installing libgnomeui i get:

-------------------------->

checking for LIBGNOMEUI... configure: error: Package requirements ( libgnome-2.0 >= 2.0.0 libgnomecanvas-2.0 >= 2.0.0 libbonoboui-2.0 >= 2.0.0 gconf-2.0 >= 1.1.11 pango >= 1.1.2 gnome-vfs-2.0 >= 2.7.3 gnome-keyring-1 >= 0.4) were not met. Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix.

Alternatively you may set the LIBGNOMEUI_CFLAGS and LIBGNOMEUI_LIBS environment variables to avoid the need to call pkg-config. See the pkg-config man page for more details.

Error: The following dependencies failed to build: gtk-sharp libgnomeui libgtkhtml3 gal libgnomeprintui gnome-icon-theme hicolor-icon-theme libgnomeprint bison libgnomecups librsvg libcroco libgsf metacity startup-notification vte gnome-session gnome-keyring Error: /opt/local/bin/port: Status 1 encountered during processing.

<-------------------------------------------

i chekced the pkg-config folder:

-------------------------->

Daniel-Oberhoffs-Computer:~ daniel$ ls /opt/local/lib/pkgconfig/ ORBit-2.0.pc gmodule-2.0.pc libgnomecanvas-2.0.pc ORBit-CosNaming-2.0.pc gmodule-export-2.0.pc libpixman.pc ORBit-idl-2.0.pc gmodule-no-export-2.0.pc libpng.pc ORBit-imodule-2.0.pc gnome-mime-data-2.0.pc libpng12.pc atk.pc gnome-vfs-2.0.pc libxml-2.0.pc audiofile.pc gnome-vfs-module-2.0.pc libxslt.pc bonobo-activation-2.0.pc gobject-2.0.pc mint.pc cairo.pc gthread-2.0.pc mono-nunit.pc dotnet.pc gtk+-2.0.pc mono.pc esound.pc gtk+-x11-2.0.pc pango.pc fontconfig.pc libIDL-2.0.pc pangocairo.pc freetype2.pc libart-2.0.pc pangoft2.pc gconf-2.0.pc libbonobo-2.0.pc pangox.pc gdk-2.0.pc libbonoboui-2.0.pc pangoxft.pc gdk-pixbuf-2.0.pc libexslt.pc render.pc gdk-pixbuf-xlib-2.0.pc libgda.pc xft.pc gdk-x11-2.0.pc libglade-2.0.pc xrender.pc glib-2.0.pc libgnome-2.0.pc

<-------------------------------------------

which told me that gno-keyring was not installed, cheking on the darwinports page told me that gnome-keyring is not listed as dependency for libgnomeui as i guess it should be. so after port install libgnomeui it all seems to go fine.

Change History (3)

comment:1 Changed 15 years ago by mww@…

Owner: changed from darwinports-bugs@… to gnome-darwinports@…
Summary: dependency of libgnomeui gnome-keyring not resolvedBUG: dependency of libgnomeui gnome-keyring not resolved

comment:2 Changed 15 years ago by rhwood@…

Committed to CVS.

Please close this bug, marking it a duplicate of bug 5703.

Thank you.

Sorry about the long response time.

comment:3 Changed 15 years ago by daniel@…

Resolution: duplicate
Status: newclosed

* This bug has been marked as a duplicate of 5703 *

Note: See TracTickets for help on using tickets.